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Article ID: 945602 - Last Review: May 13, 2008 - Revision: 2.0

Users who use Outlook 2003 cannot publish their free/busy data in Exchange Server 2007

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SYMPTOMS

Users who use Microsoft Office Outlook 2003 cannot publish their free/busy data in Microsoft Exchange Server 2007. Only hash marks appear in the free/busy data for these users. Additionally, the following event is logged in the Application log:

Event ID : 8207
Category : General
Source : MSExchangeFBPublish
Type : Error
Message : Error updating public folder with free/busy information on virtual machine <Exchange2007ServerName> . The error number is 0x80004005

When you run the Outlook /cleanfreebusy command, you receive the following error message:
Unable to clean your freebusy information
This behavior can occur in the following scenarios.

Scenario 1

Users have mailboxes in an Exchange Server 2007 environment that does not include other versions of Exchange Server.

Scenario 2

Users were migrated from Microsoft Exchange 2000 Server or from Exchange Server 2003 to Exchange Server 2007.

After this migration, all Exchange 2000 Server or Exchange Server 2003 installations in the organization were decommissioned.

CAUSE

This problem occurs because the Exchange 2007 Server public folder database is missing the following replicas.

Scenario 1 cause

The "Schedule+ Free/Busy" system folder replica is missing.

Scenario 2 cause

  • The "Schedule+ Free/Busy" system folder replica is missing on the servers that were running Exchange Server 2003.
  • The Exchange 2000 Server Administrative Group replica is missing.

RESOLUTION

To resolve this problem, follow the steps that are appropriate for your situation.

Scenario 1 resolution

  1. In the Exchange Management Shell, run the following command:
    get-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Recurse |fl
  2. Verify that the replica object for SCHEDULE+ FREE BUSY exists in the administrative group. In the following example, the administrative group (EX:/o=ORG NAME/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)) has no replica object for SCHEDULE+ FREE BUSY. Therefore, users cannot see SCHEDULE+ FREE BUSY data when they view details for the free/busy data folder.

    For example, free/busy data may appear as follows.

    Name : EX:/o=ORG NAME/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
    ParentPath : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
    Replicas : {}
  3. In the Exchange Management Shell, run the following command:
    set-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=ORG NAME/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)" -replicas "Server\Second Storage Group\Public Folder Database"
    Note This command syntax assumes that the Exchange Server 2007 public folder database is in the default location under the second storage group.
  4. Verify that the legacy administrative group now has a replica object. In the following example, the free/busy data shows a replica object.
    get-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Recurse |fl

    Name : EX:/o=ORG NAME/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
    ParentPath : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
    Replicas : {Public Folder Database}

Scenario 2 resolution

  1. In the Exchange Management Shell, run the following command:
    get-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Recurse |fl
  2. Verify that the replica object for SCHEDULE+ FREE BUSY exists in the legacy administrative groups. In the following example, the legacy administrative group (EX:/o=ORG NAME/ou=Legacy Administrative Group) has no replica object for SCHEDULE+ FREE BUSY. Therefore, users who were migrated from the legacy administrative groups cannot see SCHEDULE+ FREE BUSY data when they view details for the free/busy data folder. For example, free/busy data may appear as follows.
    Name : EX:/o=ORG NAME/ou=Legacy Administrative Group
    ParentPath : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
    Replicas : {}
  3. In the Exchange Management Shell, run the following command:
    set-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=ORG NAME/ou=Legacy Administrative Group" -replicas "Server\Second Storage Group\Public Folder Database"
    Note This command syntax assumes that the Exchange Server 2007 public folder database is in the default location under the second storage group.
  4. Verify that the legacy administrative group now has a replica object. In the following example, the free/busy data shows a replica object.
    get-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Recurse |fl

    Name : EX:/o=ORG NAME/ou=Legacy Administrative Group
    ParentPath : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
    Replicas : {Public Folder Database}
The free/busy data no longer shows hash marks for users who were migrated from legacy administrative groups to Exchange Server 2007.

Note All users whose free/busy data is not populated must accept or decline a meeting request to populate the free/busy data.

MORE INFORMATION

You must not delete any Exchange Server 2003 legacy administrative groups that contained mailboxes at any point in time. The legacyExchangeDN attribute for each user still references the old administrative groups. As long as clients are using versions of Outlook before Outlook 2007, the legacyExchangeDN attributes are used to find the free/busy data. If the administrative group no longer exists, we can no longer guarantee that the free/busy data folder will exist for users who have the matching legacyExchangeDN attribute. These users might have problems finding or publishing free/busy information. Additionally, legacyExchangeDN attributes are used when Exchange Server 2007 uses the Outlook client to delegate access to folders.

APPLIES TO
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbtshoot kbexpertiseinter kbprb KB945602

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