Article ID: 945630 - Last Review: December 5, 2007 - Revision: 1.1

Passwords are not updated in the destination directory after you configure Inbound Automatic Synchronization in Solution for Hosted Messaging and Collaboration 4.0

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SYMPTOMS

When a password is changed in the source directory, the password is not updated in the destination Active Directory directory service. You experience this problem after you configure the Inbound Automatic Synchronization scenario of the Customer Directory Integration (CDI) feature in Microsoft Solution for Hosted Messaging and Collaboration (HMC) 4.0.

Note The source directory is also known as the customer directory. The destination directory is also known as the Service Provider directory.

You experience this problem even if you follow the deployment instructions that are available on the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/cc526387.aspx (http://technet.microsoft.com/en-us/library/cc526387.aspx)

CAUSE

This problem occurs if the agent account under which the synchronization operation runs does not have sufficient rights in the destination Active Directory.

A step is missing from the deployment instructions in Hosted Messaging and Collaboration 4.0. The deployment instructions should instruct you to add the MIISService account and the MIISAgentSvc account to the Windows-based Hosting Service Accounts group.

RESOLUTION

To resolve this problem, add the MIISService account and the MIISAgentSvc account to the Windows-based Hosting Service Accounts group. To do this, follow these steps:
  1. Start the Active Directory Users and Computers tool. To do this, click Start, click Run, type dsa.msc, and then click OK.
  2. In the navigation pane, locate and then click the Users container.
  3. In the details pane, double-click the Windows-based Hosting Service Accounts group.
  4. In the Windows-based Hosting Service Accounts Properties dialog box, click the Members tab, and then click Add.
  5. In the Enter the object names to select box, type miisservice; miisagentsvc, and then click Check Names.
  6. Click OK, click Apply, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
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kbtshoot kbprb KB945630