FIX: You cannot start a Terminal Services session on a server that is running BizTalk Server 2006 after a memory leak occurs in the BizTalk Server service

Article translations Article translations
Article ID: 945719 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario. In Microsoft BizTalk Server 2006, a memory leak may occur in the BizTalk Server service. In this scenario, you cannot start a Terminal Services session on the server that is running BizTalk Server. Microsoft Message Queuing, also known as MSMQ, generates an "Insufficient Resources" error message. This problem may occur when some Message Queuing receive locations are enabled and are heavily used.

CAUSE

This problem occurs because the following conditions are true:
  • The credentials for the Message Queuing queue are configured on the BizTalk Message Queuing receive locations.
  • The Message Queuing queue is a remote public queue.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft BizTalk Server 2006 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have BizTalk Server 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapter.msmq.msmqadapter.dll3.5.1748.091,20822-Feb-200810:47x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 945719 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server 2006 Standard Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Adapter for MSMQ 2.0
Keywords: 
kbbiztalk2006presp1fix kbbtsadapters kbexpertiseinter kbfix kbqfe KB945719

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com