The "eseutil /k" command takes a long time to verify the checksum of transaction logs in Exchange Server 2007 Service Pack 1

Article translations Article translations
Article ID: 945877 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

On a computer that is running Microsoft Exchange Server 2007 Service Pack 1 (SP1), you use the eseutil /k command to verify the checksums of some transaction logs. However, the time that is required to verify the checksums increases as the number of transaction logs increases. For example, it may take 10 minutes to verify the checksums of 10,000 transaction logs. However, it may take 30 minutes to verify the checksums for 20,000 logs. The time to verify the checksums increases exponentially.

CAUSE

This issue occurs because the transaction logs are verified one at a time, and the original arithmetic for searching the next file is inefficient.

RESOLUTION

To resolve this problem, install Update Rollup 9 for Exchange 2007 Service Pack 1. For more information about Update Rollup 9 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:
Description of Update Rollup 9 for Exchange Server 2007 Service Pack 1
For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 945877 - Last Review: July 17, 2009 - Revision: 1.1
APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbhotfixrollup kbfix kbqfe kbexpertiseadvanced KB945877

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com