FIX: You cannot open certain work items after you install Visual Studio 2005 Team Explorer and then install Visual Studio 2008 Team Explorer on the same computer

Article translations Article translations
Article ID: 946075 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario. You install Microsoft Visual Studio 2005 Team Explorer. Then, you install Microsoft Visual Studio 2008 Team Explorer on the same computer. In this scenario, you may experience either of the following symptoms.

Symptom 1

If you open a work item in Microsoft Office Excel in one version of Team Explorer, you cannot open any work items in the other version of Team Explorer.

Symptom 2

If you uninstall one version of Team Explorer, you cannot open any work items in Excel or in Microsoft Office Project in the remaining version of Team Explorer.

CAUSE

This problem occurs because Microsoft Office integration is unstable if you install Visual Studio 2005 Team Explorer and then install Visual Studio 2008 Team Explorer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft.

To download this hotfix from the Microsoft Developer Network (MSDN) Code Gallery, visit the following Microsoft Web site:
http://code.msdn.microsoft.com/KB946075
Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Note Alternatively, you can download this hotfix rollup from the following Microsoft Connect Web site:
https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=27215

Prerequisites

You must have Visual Studio 2005 Team Explorer and Visual Studio 2008 Team Explorer installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Microsoft.TeamFoundation.OfficeIntegration.Common.dll8.0.50727.1803303,10407-Dec-200707:44

Note After you apply this hotfix, Visual Studio 2005 Team Explorer and Visual Studio 2008 Team Explorer work correctly regardless of the order in which you install the programs.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If you uninstall Visual Studio 2008 Team Explorer but do not uninstall Visual Studio 2005 Team Explorer, you must run a repair utility on Visual Studio 2005 Team Explorer.

REFERENCES

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 946075 - Last Review: January 18, 2008 - Revision: 1.1
APPLIES TO
  • Microsoft Visual Studio 2005 Team Foundation Server
Keywords: 
kbfix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB946075

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com