Help and Support
 

powered byLive Search

Error message when you try to upgrade Windows Vista to a more advanced version of Windows Vista: "Windows could not configure one or more system components To install Windows, restart the computer and then restart the installation"

Article ID:946078
Last Review:December 13, 2007
Revision:1.1

SYMPTOMS

When you try to upgrade Windows Vista to a more advanced version of Windows Vista, you may receive the following error message:
Windows could not configure one or more system components. To install Windows, restart the computer and then restart the installation.
For example, you may receive this error message when you try to upgrade Windows Vista Home Basic to Windows Vista Ultimate.

Back to the top

CAUSE

This problem occurs because some features of Windows Vista cannot be migrated to the upgraded version of Windows Vista.

Back to the top

RESOLUTION

To resolve this problem, follow these steps:
1.Click Start, type Programs and Features in the Start Search box, and then click Programs and Features in the Programs list.
2.Under Tasks, click Turn Windows features on or off.
If you are prompted for an administrator password, type the password. If you are prompted for confirmation, click Continue.
3.Click to clear the check boxes of the following features:
Microsoft .NET Framework 3.0\XPS Viewer
Remote Differential Compression
Window DFS Replication Service
4. Upgrade Windows Vista to a more advanced version, and then click to select the check boxes that you clicked to clear in step 3.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top


APPLIES TO
Windows Vista Business
Windows Vista Enterprise
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate
Windows Vista Business 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business N
Windows Vista Business N 64-bit Edition
Windows Vista Home Basic N
Windows Vista Home Basic N 64-bit Edition

Back to the top

Keywords: 
kbtshoot kbprb kbexpertisebeginner KB946078

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.