Aplikace Outlook 2003 nebo Outlook 2007 neočekávaně ukončena po uzavření e-mailovou zprávu v klientovi Microsoft Dynamics CRM 3.0 pro aplikaci Outlook

Překlady článku Překlady článku
ID článku: 946131 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Po instalovat klienta Microsoft Dynamics CRM 3.0 pro stolní počítače Aplikace Microsoft Office Outlook nebo klienta Microsoft Dynamics CRM 3.0 pro přenosné počítače Aplikace Microsoft Office Outlook v počítači se systémem aplikace Microsoft Office Outlook 2003 nebo aplikace Microsoft Office Outlook 2007, Outlook 2003 nebo Outlook 2007 je neočekávaně ukončena a poté Po zavření restartuje e-mailové zprávy v aplikaci Outlook.

Pokud platform trasování je povoleno, je zobrazit chybové zprávy v souboru trasování platformy, podobné následující:
[Datum čas] Proces: OUTLOOK |Podproces: 3024 |Kategorie: Unmanaged.Platform |Uživatel: PlatformUser |Úroveň: Chyba | CMAPIEventsListener::OnStoreNotify() přijala oznámení typu 16 funkce: CMAPIEventsListener::OnStoreNotify Souboru: z:\crm\v3rtm-2\src\application\outlook\addin\mapieventslistener.cpp řádek: 384

[Datum čas] Proces: OUTLOOK |Podproces: 3024 |Kategorie: Unmanaged.Platform |Uživatel: PlatformUser |Úroveň: Chyba | CMAPIEventsListener::OnStoreNotify() přijala oznámení typu 16 funkce: soubor CMAPIEventsListener::OnStoreNotify: z:\crm\v3rtm-2\src\application\outlook\addin\mapieventslistener.cpp řádek: 384

[Datum čas] Proces: OUTLOOK |Podproces: 3024 |Kategorie: Unmanaged.Platform |Uživatel: PlatformUser |Úroveň: Chyba | Inspektor obálka s id {7E6EB0A0-F4A4-DC11-900E-0003FF239E2E} byl vypnut funkce: Soubor CInspectorWrapper::InspectorShutdown: z:\crm\v3rtm-2\src\application\outlook\addin\inspectorwrapper.cpp řádek: 858

[Datum čas] Proces: OUTLOOK |Podproces: 3024 |Kategorie: Unmanaged.Platform |Uživatel: PlatformUser |Úroveň: Chyba | Inspektor obálka s id {4C169BB1-F4A4-DC11-900E-0003FF239E2E} byl vypnut funkce: soubor CInspectorWrapper::InspectorShutdown: z:\crm\v3rtm-2\src\application\outlook\addin\inspectorwrapper.cpp řádek: 858
Tato zpráva se může zobrazit, pokud jste povolili trasování platformy pomocí metody, která je popsána v článku znalostní báze Microsoft Knowledge Base 907490.

Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
907490Povolení trasování v aplikaci Microsoft Dynamics CRM
Tato chybová zpráva v trasovací soubory platformy, počínaje jméno v následujícím formátu:
APLIKACE OUTLOOK- xxxxxxxxxxlog
Na xxxxxxxxxx zástupný symbol představuje rok, měsíc, den a čas souboru trasování platformy.

Navíc je může se zobrazit události v protokolu aplikace který vypadat takto:
Zdroj: Microsoft Office 11
Kategorie: žádný
ID události: 1002
Předsazení aplikace OUTLOOK.EXE, verze 11.0.8118.0, zablokuje modul hungapp, verze 0.0.0.0, zablokuje adresu 0x00000000.
Další informace naleznete v nápovědě a odborné pomoci na adrese http://go.microsoft.com/fwlink/events.ASP.

Zdroj: Microsoft Office 11
Kategorie: žádný
ID události: 1000
Chybující aplikace outlook.exe, verze 11.0.8118.0, razítko 456628bf, chybující modul outllib.dll, verze 11.0.8118.0, razítko 4566283d, ladění? 0, adresa chyby 0x002492bb. Další informace informace naleznete v tématu nápovědy a odborné pomoci na adrese http://go.microsoft.com/fwlink/events.ASP.
To problém nenastane, pokud jste nainstalovali klientů Microsoft Dynamics CRM 3.0 Aktualizace kompatibility aplikace Microsoft Office Outlook.

Příčina

K tomuto problému dochází, pokud jste nainstalovali opravu hotfix 924085 Aplikace Outlook 2003 nebo Outlook 2007.

Řešení

Tento problém byl opraven v kumulativní aktualizaci 3 produktu Microsoft Dynamics CRM 3.0.Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
935364Kumulativní aktualizace 3 je k dispozici pro aplikaci Microsoft Dynamics CRM 3.0

Microsoft Dynamics CRM 3.0, japonské nebo čínské verze

Tento problém je vyřešen v zjednodušenou verzi Microsoft Dynamics CRM 3.0 a v japonské verzi kumulativní aktualizace 2 produktu Microsoft Dynamics CRM 3.0. Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
944372Je k dispozici kumulativní aktualizace 2 pro zjednodušenou verzi Microsoft Dynamics CRM 3.0 a japonské verze aplikace Microsoft Dynamics CRM 3.0

Informace o opravě hotfix pro aplikaci Microsoft Dynamics CRM 3.0

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Informace o souboru

Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo karty v Datum a čas Chcete-li zobrazit položky v Ovládacích panelech.

Klienta Microsoft Dynamics CRM 3.0 pro aplikaci Outlook

Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasHodnoty hashPlatforma
Soubor crmaddin.dll3.0.5300.18021,193,48831. Ledna-200823: 35MD5: 181368D572E11D1FD3E1F4B191BB3590
SHA1: 8A634F1AFE3714C7F920E9BC129F62BF55F71330
x 86

Klient Microsoft Dynamics CRM 3.0 pro aplikaci Outlook

Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasHodnoty hashPlatforma
Soubor crmaddin.dll3.0.5300.18021,219,60031. Ledna-200823: 35MD5: DBBF97DDFA7E3ABA846F0C6501F77DDD
SHA1: 5FB9E508CE8DA42D26290A62EB9C8F13738A1DE1
x 86
Syncqueue.dll3.0.5300.1802395,79231. Ledna-200823: 34MD5: 20BD719018C9A3DFAC47A49E8657F4FA
SHA1: 90632E8CFB4B8BD1A072D351962D5DD6A7BAF4BF
x 86
Soubor crmaddin.dll3.0.5300.18021,219,60031. Ledna-200823: 35MD5: DBBF97DDFA7E3ABA846F0C6501F77DDD
SHA1: 5FB9E508CE8DA42D26290A62EB9C8F13738A1DE1
x 86

Informace o instalaci

Důležité Tento oddíl, metoda nebo úkol obsahuje kroky, které informace o úpravě registru. Však mohou nastat závažné problémy při nesprávných úpravách registru. Proto se ujistěte, opatrně postupujte takto. Pro zvýšení ochrany před úpravami je nutné zálohujte registr. Můžete pak obnovení registru v případě, že dojde k potížím. Další informace o zálohování a obnovení registru získáte článku znalostní báze Microsoft Knowledge Base:
322756 Postup při zálohování a obnovení registru v systému Windows
Instalaci této opravy hotfix do počítačů se systémem klienta Microsoft Dynamics CRM 3.0 pro aplikaci Outlook.

K vyřešení tohoto problému postupujte takto:
  1. Ukončete aplikaci Outlook pomocí Správce úloh systému Windows.
  2. Klepněte na tlačítko Spustit, klepněte na tlačítko Spustit, Typ regedita klepněte na tlačítko OK.
  3. Vyhledejte a klepněte na následující položky registru:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient
  4. Vyhledejte podklíč CallInspectorClose.

    Pokud CallInspectorClose nemá podklíč neexistuje, vytvořte CallInspectorClose podklíč. Chcete-li to provést, postupujte takto:
    1. V Upravit příkaz Novýa klepněte na tlačítko Hodnota DWORD.
    2. Typ CallInspectorClose, a stiskněte klávesu ENTER.
  5. Klepněte pravým tlačítkem myši CallInspectorClosea pak Klepněte na tlačítko Upravit.
  6. V Hodnota dat Typ pole0x00000000a klepněte na tlačítko OK.

    Poznámky
    • Máte-li aplikaci Outlook 2003 nebo Outlook 2007 instalaci a Nemáte žádné opravy hotfix nainstalována, 924085 hodnotu z Podklíč CallInspectorClose musí být nastavena 0x00000001. Nebo můžete odebrat v podklíči CallInspectorClose.
    • Je-li nainstalována aplikace Outlook 2003 nebo Outlook 2007 a máte k dispozici oprava hotfix nainstalována, 924085 hodnota Podklíč CallInspectorClose musí být nastavena na 0x00000000, aby zabránily zhroucení. Pokud není nastaveno v podklíči CallInspectorClose 0x00000000, paměť nevrací může dojít po ukončení okno v aplikaci Outlook.

Požadavky

Musíte mít kumulativní aktualizace 2 pro aplikaci Microsoft Dynamics CRM 3.0 nainstalovat tuto opravu hotfix. Další informace o kumulativní aktualizaci 2 pro aplikaci Microsoft Dynamics CRM 3.0 naleznete v následujících článcích znalostní báze, klepněte na tlačítko Znalostní báze Microsoft Knowledge Base:
927751Je k dispozici kumulativní aktualizace 2 pro aplikaci Microsoft Dynamics CRM 3.0

Požadavek na restartování

Pokud se zobrazí výzva, restartujte počítač po instalaci oprava hotfix.

Informace o odinstalaci

Chcete-li odebrat tuto opravu hotfix z počítače se systémem Windows Server 2003, Windows XP nebo Windows 2000, použijte následující příkaz: Přidat nebo odebrat programy v Ovládacích panelech.Správci systému mohou pomocí nástroje Spuninst.exe odebrat tuto opravu hotfix z počítače se systémem Windows Server 2003, Windows XP nebo systému Windows 2000.

Nástroj Spuninst.exe je umístěn ve složce %Windir%\$NTUninstallKB946131$\Spuninst.

Jak potíže obejít

Chcete-li tento problém vyřešit, odinstalujte Microsoft Klient plochy Dynamics CRM 3.0 pro aplikaci Outlook nebo Microsoft Dynamics CRM přenosné počítače 3.0 pro Outlook.Then, znovu Klienti aplikace Microsoft Dynamics CRM 3.0 pro aplikaci Microsoft Aktualizace kompatibility aplikace Office Outlook.

Další informace o Klienti aplikace Microsoft Dynamics CRM 3.0 pro aplikaci Microsoft Aktualizace kompatibility aplikace Office Outlook, naleznete na následujícím webu:
http://www.microsoft.com/downloads/details.aspx?FamilyId = 740E1B3B-11 C 3-4AEF-B2E3-8309E0CF1BB0 & displaylang = cs

Další informace

Další informace o terminologie používané při popisu aktualizací softwaru společnosti Microsoft, klepněte naleznete v následujících článcích báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
887283 Aktualizace a opravy hotfix pro aplikaci Microsoft Business Solutions CRM software balíček standardy používání názvů
Další informace o opravě hotfix 924085 klepnutím na následující článek znalostní báze Microsoft Knowledge Base:
924085Popis aktualizace zabezpečení pro aplikaci Outlook 2003: 9. ledna 2007
Další informace o použití ADPlus Odstraňování problémů s "reagovat" a "zhroucení", klepnutím na následující číslo článku zobrazení článku znalostní báze Microsoft Knowledge Base:
286350Jak používat Poradce při potížích s ADPlus "reagovat" a "zhroucení"

Vlastnosti

ID článku: 946131 - Poslední aktualizace: 22. května 2011 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft CRM client for Microsoft Office Outlook
Klíčová slova: 
kbautohotfix kberrmsg kbhotfixserver kbqfe kbmbsmigrate kbmt KB946131 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:946131

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com