You are prompted to install a new printer driver in Windows Vista when you try to print to a Windows Server 2008-based print server or to a Windows Server 2003-based print server

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Article ID: 946225 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. You use a Windows Vista-based computer to print documents on a shared printer that is hosted by a Windows Server 2008-based print server or by a Windows Server 2003-based print server. Additionally, one of the following conditions is true:
  • An administrator installed an additional printer on the print server.
  • An administrator updated a printer driver for another printer on the print server.
  • System files that are used directly by the printer drivers, such as unidrv.dll or pscript5.dll, are updated on the print server.
In this scenario, you receive the following message:
To use \\Print_Server\Printer, you need to install the printer driver on your computer and then restart the print job. If you do not recognize or trust the name and location of the printer, do not install the driver.
Also, Driver Update Needed is displayed in the Status field in the Printers folder in Control Panel.

If you click Install driver, and you have administrator user rights, you can continue to print.

CAUSE

This problem occurs if the printer driver is automatically updated by a Windows Server 2008 print server or by a Windows Server 2003 print server. When an administrator updates a printer driver on a shared print server, the Point and Print feature automatically updates printer drivers from the print server to a client computer. Some printers may share driver files across several printer models or across a family of printers. An update to one of these shared driver files will cause client computers to update the drivers for any device that depends on the updated files. To help improve security, Windows Vista displays a dialog box that prompts you to install the updated driver.

The document that is located at the following Microsoft Web site contains more information on the Point and Print feature and on how Windows determines whether a driver file has been updated:
http://www.microsoft.com/windowsserver2003/techinfo/overview/pointandprint.mspx

RESOLUTION

If you experience this problem in a corporate environment, you must contact the network administrator for help.

MORE INFORMATION

More information for network administrators

If you are a network administrator, and this problem occurs on client computers in the network, you can resolve this problem by applying modified Group Policy settings to the client computers. For more information about Group Policy, visit the following Microsoft Web site:
http://www.microsoft.com/windowsserver2003/gpmc/default.mspx
For more information about how to modify the behavior of Point and Print to bypass additional security in Windows Vista by using the Point and Print Restrictions Group Policy setting, view the document that is located at the following Microsoft Web site:
http://www.microsoft.com/whdc/device/print/VistaPnPSec.mspx
When the additional security in Windows Vista is bypassed, users will not see any warning messages under either of the following conditions:
  • Users connect to a shared printer, and then Point and Print installs a new printer driver.
  • Point and Print updates the printer driver for an existing connection.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 946225 - Last Review: June 26, 2009 - Revision: 2.0
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Keywords: 
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