Artikel-ID: 946286 - Geändert am: Mittwoch, 2. April 2008 - Version: 2.0

Fehlermeldung, wenn Sie, zur Anmeldung auf Microsoft Dynamics CRM 4.0 versuchen: "Datenbank kann nicht geöffnet ' [Organization] _MSCRM" von der Anmeldung angeforderte "

SystemtippDieser Artikel bezieht sich auf ein anderes Betriebssystem als das von Ihnen verwendete. Für Sie möglicherweise nicht relevante Artikelinhalte wurden deaktiviert.

Auf dieser Seite

Alles erweitern | Alles schließen

Problembeschreibung

Sie installieren Microsoft Dynamics CRM 4.0. Wenn Sie versuchen, Microsoft Dynamics CRM 4.0 anmelden, wird sinngemäß die folgende Fehlermeldung:
Kann Datenbank Organization _MSCRM" von der Anmeldung angeforderte nicht öffnen.
Fehler bei der Anmeldung. Fehler bei der Anmeldung für den Benutzer "NT AUTHORITY\NETWORK SERVICE".
Wenn der DevErrors -Wert in der Datei Web.config auf On festgelegt ist, erhalten Sie eine Fehlermeldung etwa folgenden Inhalts angezeigt:
Serverfehler in Anwendung '/'.

Datenbank "MSCRM_CONFIG" von der Anmeldung angeforderte kann nicht geöffnet werden. Fehler bei der Anmeldung.
Fehler bei der Anmeldung für den Benutzer ' Domain \ CRMServer$ ".
Beschreibung: Bei der Ausführung der aktuellen Webanforderung ist eine nicht behandelte Ausnahme aufgetreten. Überprüfen Sie die Stapelüberwachung, um weitere Informationen über diesen Fehler anzuzeigen und festzustellen, wo dieser Fehler im Code verursacht wurde.

Ausnahmedetails: System.Data.SqlClient.SqlException: "MSCRM_CONFIG" von der Anmeldung angeforderte Datenbank kann nicht geöffnet. Fehler bei der Anmeldung. Fehler bei der Anmeldung für den Benutzer ' Domain \ CRMServer$ ".

Quellfehler:

Während der Ausführung der aktuellen Webanforderung wurde eine unbehandelte Ausnahme generiert. Informationen über den Ursprung und die Position der Ausnahme kann mit der Ausnahmestapelüberwachung unten identifiziert werden.

Stapelüberwachung:

[SqlException (0x80131904): "MSCRM_CONFIG" von der Anmeldung angeforderte Datenbank kann nicht geöffnet. Fehler bei der Anmeldung.
Fehler bei der Anmeldung für den Benutzer ' Domain \ CRMServer$ ".]

System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject) +437

System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection) + 82

System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory) +105
System.Data.SqlClient.SqlConnection.Open() +111
Microsoft.Crm.CrmDbConnection.Open() + 386

Microsoft.Crm.SharedDatabase.DatabaseMetadata.LoadMetadataXmlFromDatabase (CrmDBConnectionType ConnectionType, String ConnectionString, Int32 & MaxBlobSize) +125

Microsoft.Crm.SharedDatabase.DatabaseMetadata.LoadCacheFromDatabase(CrmDBConnectionType connectionType, String connectionString) + 65
Microsoft.Crm.ConfigurationDatabase.ConfigurationMetadata.LoadCache() +41
Microsoft.Crm.ConfigurationDatabase.ConfigurationMetadata.get_Cache() +114

Microsoft.Crm.ConfigurationDatabase.ConfigurationDatabaseService.InitializeMetadataCache() +28
Microsoft.Crm.SharedDatabase.DatabaseService.Initialize(String tableName) +53
Microsoft.Crm.SharedDatabase.DatabaseService.Retrieve(String tableName, String[] Columns, PropertyBag[] Conditions) +109
Microsoft.Crm.ServerLocatorService.GetSiteSettingIdFromDatabase() +155
Microsoft.Crm.ServerLocatorService.GetSiteSettingId() +187
Microsoft.Crm.ServerLocatorService.GetSiteSetting(String settingName) + 82
Microsoft.Crm.LocatorService.GetSiteSetting(String settingName) +35
Microsoft.Crm.CrmTrace.get_RefreshTrace() +654

Versionsinformationen: Microsoft .NET Framework-Version:2.0.50727.832; ASP.NET Version: 2.0.50727.832

Ursache

Dieses Problem tritt auf, wenn eine oder mehrere der folgenden Bedingungen erfüllt sind:
  • Sie installieren Microsoft Dynamics CRM 4.0 in einer Umgebung mit mehreren Servern. Anschließend installieren Sie Microsoft Dynamics CRM 4.0 direkt auf einem Server, auf dem Microsoft SQL Server ausgeführt wird. Allerdings sind einige SQL Server Berechtigungen nicht festgelegt.
  • Der Microsoft Dynamics CRM 4.0-Server wird der Gruppe "SQLAccessGroup" in Active Directory-Verzeichnisdienst nicht hinzugefügt.

Lösung

Um dieses Problem zu beheben, verwenden Sie eine oder mehrere der folgenden Methoden.

Methode 1

Richten Sie das NT-AUTORITÄT\NETZWERKDIENST-Konto als ein SQL Server-Benutzer mit Zugriff auf die Microsoft Dynamics CRM 4.0-Datenbanken. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start , zeigen Sie auf Programme , zeigen Sie auf Microsoft SQL Server 2005 und klicken Sie dann auf SQL Management Studio .
  2. Um zu SQL Server Management Studio anzumelden, klicken Sie auf OK .
  3. Im Objekt-Explorer erweitern Sie Datenbanken , erweitern Sie die Organization MSCRM -Datenbank, und erweitern Sie dann Sicherheit .
  4. Klicken Sie mit der rechten Maustaste auf Users , und klicken Sie dann auf Neuer Benutzer .
  5. Geben Sie NT AUTHORITY\NETWORK SERVICE in den folgenden Feldern klicken Sie im Dialogfeld Datenbankbenutzer ? neu :
    • Das Feld Benutzer-name
    • Das Feld Login-name
  6. Klicken Sie im Bereich Datenbank Rollenmitgliedschaft auf das Kontrollkästchen Db_owner aktivieren, und klicken Sie dann auf OK .

Methode 2

Fügen Sie den Microsoft Dynamics CRM 4.0-Server zu der Gruppe "SQLAccessGroup" in Active Directory hinzu. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie dsa.msc ein und klicken Sie dann auf OK .
  2. Klicken Sie auf die Organisationseinheit, in der Sie Microsoft Dynamics CRM 4.0 installieren.
  3. Doppelklicken Sie auf "SQLAccessGroup" .
  4. Klicken Sie im Dialogfeld SQLAccessGroup klicken Sie auf Mitglieder , klicken Sie auf Hinzufügen , klicken Sie auf Objekttypen , klicken Sie dann auf das Kontrollkästchen Computer und klicken Sie dann auf OK .
  5. Geben Sie im Feld Geben Sie die zu verwendenden Objektnamen den Namen des Microsoft Dynamics CRM 4.0-Servers und klicken Sie auf Namen überprüfen .
  6. Stellen Sie sicher, dass der Name des Microsoft Dynamics CRM 4.0-Servers im Feld Geben Sie die zu verwendenden Objektnamen verfügbar ist, und klicken Sie dann zwei Mal auf OK .
  7. Starten Sie den Microsoft Dynamics CRM 4.0-Server neu.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbmt kberrmsg kbexpertiseinter kbhowto kbmbsmigrate kbexpertisebeginner kbinfo kbprb kbtshoot KB946286 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 946286  (http://support.microsoft.com/kb/946286/en-us/ )
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.