Mensaje de error cuando intenta iniciar sesión en Microsoft Dynamics CRM 4.0: "no se puede abrir base de datos ' [organización] _MSCRM ' solicitada por el inicio de sesión"

Seleccione idioma Seleccione idioma
Id. de artículo: 946286 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Instala Microsoft Dynamics CRM 4.0. Cuando intenta iniciar sesión en Microsoft Dynamics CRM 4.0, recibirá el siguiente mensaje de error:
No se puede abrir la base de datos Organization _MSCRM" solicitada por el inicio de sesión.
Error el inicio de sesión. Error de inicio de sesión para el usuario 'NT AUTHORITY\NETWORK SERVICE'.
Si se establece el valor DevErrors en on en el archivo Web.config, recibirá un mensaje de error similar al siguiente:
Error de servidor en la aplicación '/'.

No se puede abrir la base de datos "MSCRM_CONFIG" solicitada por el inicio de sesión. Error el inicio de sesión.
Error de inicio de sesión del usuario ' Domain \ CRMServer$ '.
Descripción: Se produjo una excepción no controlada durante la ejecución de la solicitud web actual. Revise la traza de la pila para obtener más información acerca del error y dónde se originó en el código.

Detalles de excepciones: System.Data.SqlClient.SqlException: no se puede abrir la base de datos "MSCRM_CONFIG" solicitada por el inicio de sesión. Error el inicio de sesión. Error de inicio de sesión del usuario ' Domain \ CRMServer$ '.

Error de código fuente:

Se ha generado una excepción no controlada durante la ejecución de la solicitud Web actual. La información sobre el origen y la ubicación de la excepción pueden identificarse utilizando la excepción del seguimiento de la pila siguiente.

Pila:

[SqlException (0x80131904): no se puede abrir la base de datos "MSCRM_CONFIG" solicitada por el inicio de sesión. Error el inicio de sesión.
Error de inicio de sesión del usuario ' Domain \ CRMServer$ '.]

System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject) +437

System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection) +82

System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory) +105
System.Data.SqlClient.SqlConnection.Open() +111
Microsoft.Crm.CrmDbConnection.Open() + 386

Microsoft.Crm.SharedDatabase.DatabaseMetadata.LoadMetadataXmlFromDatabase (CrmDBConnectionType connectionType, cadena connectionString, Int32 & maxBlobSize) +125

Microsoft.Crm.SharedDatabase.DatabaseMetadata.LoadCacheFromDatabase(CrmDBConnectionType connectionType, String connectionString) + 65
Microsoft.Crm.ConfigurationDatabase.ConfigurationMetadata.LoadCache() +41
Microsoft.Crm.ConfigurationDatabase.ConfigurationMetadata.get_Cache() +114

Microsoft.Crm.ConfigurationDatabase.ConfigurationDatabaseService.InitializeMetadataCache() +28
Microsoft.Crm.SharedDatabase.DatabaseService.Initialize(String tableName) +53
Microsoft.Crm.SharedDatabase.DatabaseService.Retrieve(String tableName, String[] Columns, PropertyBag[] Conditions) +109
Microsoft.Crm.ServerLocatorService.GetSiteSettingIdFromDatabase() +155
Microsoft.Crm.ServerLocatorService.GetSiteSettingId() +187
Microsoft.Crm.ServerLocatorService.GetSiteSetting(String settingName) +82
Microsoft.Crm.LocatorService.GetSiteSetting(String settingName) +35
Microsoft.Crm.CrmTrace.get_RefreshTrace() +654

Información de versión: Version:2.0.50727.832 de Microsoft .NET Framework; versión de ASP.NET: 2.0.50727.832

Causa

Se produce este problema cuando una o varias de las siguientes condiciones son verdaderas:
  • Instalar Microsoft Dynamics CRM 4.0 en un entorno de varios servidores. A continuación, instala Microsoft Dynamics CRM 4.0 directamente en un servidor que ejecuta Microsoft SQL Server. Sin embargo, no se establecen algunos permisos SQL Server.
  • El servidor de Microsoft Dynamics CRM 4.0 no se agrega al grupo SQLAccessGroup en servicio de directorio Active Directory.

Solución

Para resolver este problema, utilice uno o varios de los métodos siguientes.

Método 1

Configurar la cuenta NT AUTHORITY\NETWORK SERVICE como un usuario de SQL Server quién tiene acceso a bases de datos de Microsoft Dynamics CRM 4.0. Para ello, siga estos pasos:
  1. Haga clic en Inicio , seleccione Todos los programas , seleccione Microsoft SQL Server 2005 y, a continuación, haga clic en SQL Management Studio .
  2. Para iniciar sesión a SQL Server Management Studio, haga clic en Aceptar .
  3. En el Explorador de objetos, expanda bases de datos , expanda la base de datos Organization _MSCRM y a continuación, expanda seguridad .
  4. Haga clic con el botón secundario en usuarios y, a continuación, haga clic en Nuevo usuario .
  5. En el cuadro de diálogo de Usuario de base de datos ? nuevo , escriba NT AUTHORITY\NETWORK SERVICE en los siguientes campos:
    • El campo nombre de usuario
    • El campo nombre de inicio de sesión
  6. En el área pertenencia a funciones de base de datos , haga clic para activar la casilla de verificación db_owner y, a continuación, haga clic en Aceptar .

Método 2

Agregar el servidor de Microsoft Dynamics CRM 4.0 al grupo SQLAccessGroup en Active Directory. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba dsa.msc y, a continuación, haga clic en Aceptar .
  2. Haga clic en la unidad organizativa en la que se instala Microsoft Dynamics CRM 4.0.
  3. Haga doble clic en SQLAccessGroup .
  4. En el cuadro de diálogo SQLAccessGroup , haga clic en miembros , haga clic en Agregar , haga clic en Tipos de objetos , active la casilla de verificación equipos y, a continuación, haga clic en Aceptar .
  5. En el cuadro Escriba los nombres de objeto que desea seleccionar , escriba el nombre del servidor de Microsoft Dynamics CRM 4.0 y, a continuación, haga clic en Comprobar nombres .
  6. Compruebe que el nombre del servidor Microsoft Dynamics CRM 4.0 en el cuadro Escriba los nombres de objeto que desea seleccionar está disponible y, a continuación, haga clic en Aceptar dos veces.
  7. Reinicie el servidor de Microsoft Dynamics CRM 4.0.

Propiedades

Id. de artículo: 946286 - Última revisión: miércoles, 02 de abril de 2008 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Dynamics CRM 4.0
Palabras clave: 
kbmt kberrmsg kbexpertiseinter kbhowto kbmbsmigrate kbexpertisebeginner kbinfo kbprb kbtshoot KB946286 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 946286

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com