Microsoft Dynamics CRM 4. 0 で、レポートを実行するとエラー メッセージ:"レポートを表示できませんが表示されます"

文書翻訳 文書翻訳
文書番号: 946289 - 対象製品
制限 Microsoft Dynamics コンテンツは、「サポート技術情報」(Microsoft Knowledge Base) のパブリック Web サイトに提供します。 Microsoft Dynamics の完全なコンテンツおよび追加リソースを参照してください:

Dynamics 顧客
Microsoft Dynamics CustomerSource *
Dynamics パートナー
Microsoft Dynamics PartnerSource

* 顧客などの拡張計画の準備完了にビジネス、ソフトウェア アシュアランス Microsoft Dynamics サービス プランがある必要がある
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Dynamics CRM 4. 0 で、レポートを実行すると、次のレポートのエラー メッセージが表示されます。
エラーを報告します。
レポートを表示できません。
DevErrors パラメーターが Web.config ファイルに] に設定されて、次のエラー メッセージが表示されます。
Microsoft CRM 未処理のエラーの詳細: サーバーに '/' アプリケーション エラーが発生しました。

1 つまたは複数のデータ ソースの資格情報がありません。

説明 : 現在の Web 要求を実行中に、ハンドルされていない例外が発生しました。 エラーおよびコードで発生した詳細については、スタック トレースをご覧下さい。

例外の詳細: Microsoft.Reporting.WebForms.MissingDataSourceCredentialsException: 1 つまたは複数のデータ ソースの資格情報がありません

ソース エラー:
未処理の例外は、現在の Web 要求の実行中に生成されました。 原点と例外の場所に関する情報は、以下の例外スタック トレースを使用して識別できます。

スタック トレース:

[MissingDataSourceCredentialsException: 1 つまたは複数のデータ ソースの資格情報がありません] Microsoft.Reporting.WebForms.ParametersArea.ValidateAllReportInputsSatisfied() + 65
Microsoft.Reporting.WebForms.ReportViewer.OnPreRender(EventArgs e) +643

[CrmException: レポート レンダリング中に、エラーが発生しました:]
Microsoft.Crm.Web.Reporting.SrsReportViewer.ReportErrorHandler(Object sender, ReportErrorEventArgs e) +626
Microsoft.Reporting.WebForms.ReportViewer.OnError(Exception e) +56
Microsoft.Reporting.WebForms.ReportViewer.OnPreRender(EventArgs e) +1699
System.Web.UI.Control.PreRenderRecursiveInternal() +77
System.Web.UI.Control.PreRenderRecursiveInternal() +161
System.Web.UI.Control.PreRenderRecursiveInternal() +161
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1360
MSCRM データ ソースで Microsoft SQL Server レポート サービス (SSRS) のプロパティを確認すると、次のエラー メッセージ表示されます。
データ処理拡張機能がこのレポートの使用は利用できません。 それがアンインストールかされて、かが、正しく構成されていません。

原因

原因 1

この問題は、Microsoft Dynamics CRM 4. 0 を使用する拡張のカスタム データの処理は、SSRS サーバーに正しく登録されてために発生します。 この現象は SSRS の Microsoft Dynamics CRM データ コネクタがアンインストールされている場合、または SSRS の Microsoft Dynamics CRM データ コネクタが正しく構成されていない場合に発生する可能性があります。

SQL Server 2005 Service Pack 2 を次の重要な更新プログラムをインストールする場合は SSRS の Microsoft Dynamics CRM データ コネクタが削除されます。
http://www.microsoft.com/downloads/details.aspx?FamilyId=D09CF5C4-FEC4-4322-9FEE-06A43401CF0C&displaylang=en

原因 2

Microsoft Dynamics CRM データ コネクタ Microsoft SQL Server レポート サービスをインストールした後、データの文字列は変更されません。

解決方法

解決策 1

この問題を解決をするには修復または Microsoft SQL Server レポート サービスは、Microsoft Dynamics CRM データ コネクタを再インストールします。

解決方法 2

手動で接続文字列とデータ ソースを変更する必要がありますを変更します。 これを行うには、次の手順を実行します。
  1. レポート マネージャーを開きます。
  2. CRM 組織を選択します。
  3. 詳細を表示] をクリックします。
  4. v4 フォルダーをクリックします。
  5. データ ソースの CRM をクリックします。

    Windows 認証を使用する場合、接続文字列はようになります。
    データ ソース = サーバー; Initial Catalog ORG_MSCRM; = 統合セキュリティ SSPI =
    Windows が統合認証オプションを選択します。
    Microsoft CRM のデータ拡張機能を使用して接続文字列は、次をましょう。
    MSCRM データ コネクタの接続文字列
    ユーザーによって提供される資格情報で、レポートを実行します。

詳細

同様の問題の詳細についてはをクリックして次資料「サポート技術情報」(Microsoft Knowledge Base) 資料を参照。
946585Microsoft Dynamics CRM 4. 0 で、レポートを実行するとエラー メッセージ:"エラーを報告します。 レポートを表示できません"

プロパティ

文書番号: 946289 - 最終更新日: 2009年9月8日 - リビジョン: 5.0
この資料は以下の製品について記述したものです。
  • Microsoft Dynamics CRM 4.0
キーワード:?
kbtshoot kbprb kbmbsmigrate kbexpertiseinter kbexpertisebeginner kbmt KB946289 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:946289
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com