Artikel-ID: 946428 - Geändert am: Donnerstag, 19. April 2012 - Version: 1.0

Der Operations Manager-Healthdienst verarbeitet keine Konfigurationsdateien, und protokolliert Ereignis IDs 7022 und 1220

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Problembeschreibung

Nach der Installation von Microsoft System Center Operations Manager-Agent auf einem Windows-Domänencontroller verarbeitet den Health Service keine Konfigurationsdateien. Darüber hinaus sind Ereignisse, die den folgenden ähneln alle 30 Minuten im Anwendungsprotokoll auf dem Domänencontroller protokolliert:

Ereignis 1

Ereignistyp: Fehler
Ereignisquelle: Integritätsdienst
Ereigniskategorie: Health Service
Ereignis-ID: 7022
Datum: Datum
Zeit: Zeit
Benutzer: n/A
Computer: Computername
Beschreibung: Gesundheitswesen hat sichere Konfiguration für Verwaltungsgruppe heruntergeladen. Management_Group_Name, und Verarbeiten der Konfiguration fehlgeschlagen mit Fehler Code 0x80FF003F(0x80FF003F).

Ereignis 2

Ereignistyp: Fehler
Ereignisquelle: Integritätsdienst
Ereigniskategorie: Health Service
Ereignis-ID: 1220
Datum: Datum
Zeit: Zeit
Benutzer: n/A
Computer: Computername
Beschreibung: Die Konfiguration kann nicht verarbeitet werden. Management Group" Management_Group_Name".

Ursache

Dieses Problem tritt auf, wenn Sie ein Konto konfigurieren, die nicht als das standardmäßige Aktionskonto Administratorrechte verfügt.

System Center Operations Manager-Agent verwendet die Run As Profile mit dem Namen privilegierten Überwachung Konto Health Service-Konfiguration zu verarbeiten. Standardmäßig verwendet das privilegierte Überwachung Konto Profil das Konto Lokales System.

Wenn Sie einen Benutzer einen Domäne als das standardmäßige Aktionskonto auf einem Domänencontroller verwendet den Agent konfigurieren, wird das Health Service Lockdown-Tool (HSLockdown.exe) bei der Installation automatisch ausgeführt. Health Service Lockdown-Tool verweigert den Health Service-Zugriff auf das Sicherheitsprinzipal "NT AUTHORITY\SYSTEM".

In diesem Szenario darf nur der NT-AUTORITÄT\Authentifizierte Benutzer Sicherheitsprinzipal Zugriff auf den Dienst der Gesundheit. Aber wenn Active Directory abgesichert ist, oder der Agent ist falsch konfiguriert, das lokale Systemkonto nicht über den Sicherheitsprinzipal authentifizierte Benutzer authentifizieren, der Agent kann nicht deshalb Health Service-Konfigurationsinformationen werden.

Lösung

Um dieses Problem zu beheben, verwenden Sie eine der folgenden Methoden.

Methode 1: Konfigurieren des privilegierten Überwachung Konto Profils

Konfigurieren Sie das privilegierte Überwachung Konto Profil einen Domänenbenutzer mit Administratorrechten auf dem betroffenen Domänencontrollern. Gehen Sie dazu folgendermaßen vor:
  1. Öffnen Sie die SCOM-Konsole, und klicken Sie dann aufVerwaltung.
  2. Unter Sicherheit, mit der rechten Maustaste Führen als Konten aus, und klicken Sie dann auf Erstellen von Ausführen als Konto. Dadurch wird der erstellen Ausführen als Konto Assistent gestartet.
  3. Wählen Sie Windows Klicken Sie im Dialogfeld Ausführung als Konto-Typ im Feld. Geben Sie einen Anzeigenamen ein, und klicken Sie dann auf Weiter.
  4. Geben Sie den Benutzernamen und das Kennwort für ein Konto, das Mitglied der Administratoren Gruppe auf dem Domänencontroller, und klicken Sie dann auf Erstellen.
  5. Nachdem das ausführende Konto erstellt wird, öffnen Sie die Führen Sie als Profile Ansicht, und Doppelklicken Sie auf Privilegierte Überwachung Konto.
  6. Klicken Sie auf die Führen als Konten aus Registerkarte.
  7. Klicken Sie auf Neue.
  8. Klicken Sie auf das ausführende Konto, das Sie in Schritt 2 bis Schritt 4 erstellt haben.
  9. Klicken Sie auf den Domänencontroller in der Liste der Computer, und klicken Sie dann auf OK.
  10. Wiederholen Sie Schritte 7 bis 9 für jeden betroffenen Domänencontroller.
  11. Klicken Sie auf OK Klicken Sie im Dialogfeld Führen als Profileigenschaften aus im Dialogfeld.
  12. Starten Sie den OpsMgr Health Service auf betroffenen Domänencontrollern.

Methode 2: Ausführen von HSLockdown.exe Berechtigungen konfigurieren

Führen Sie HSLockdown.exe auf die betroffenen Domänencontroller NT Authority\SYSTEM aus der Liste verweigert entfernen. Gehen Sie dazu folgendermaßen vor:
  1. Öffnen Sie auf dem Domänencontroller eine Eingabeaufforderung, und öffnen Sie den Ordner, in dem die Agent-Software installiert ist.
  2. Geben Sie den folgenden Befehl ein, und drücken Sie dann die EINGABETASTE:
    Hslockdown"Verwaltungsgruppe _Name"/ R"NT-AUTORITÄT\SYSTEM"
    In diesem Befehl Verwaltungsgruppe _Name ist der Name der Operations Manager 2007-Verwaltungsgruppe, der der Agent angehört. Verwenden Sie Anführungszeichen, wenn der Name enthält Räume.
  3. Starten Sie den OpsMgr Health-Dienst.
  4. Wiederholen Sie die Schritte 1 bis 3 auf jedem Domänencontroller, die betroffen ist.

Informationsquellen

Weitere Informationen zu HSLockdown.exe finden Sie auf der folgenden Microsoft TechNet-Website:
http://technet.Microsoft.com/en-us/library/bb309542.aspx (http://technet.microsoft.com/en-us/library/bb309542.aspx)

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft System Center Operations Manager 2007
  • Microsoft System Center Operations Manager 2012
  • Microsoft System Center Operations Manager 2007 R2
  • Microsoft System Center Operations Manager 2007 Service Pack 1
Keywords: 
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 946428  (http://support.microsoft.com/kb/946428/en-us/ )
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