Artigo: 946428 - Última revisão: quinta-feira, 19 de Abril de 2012 - Revisão: 1.0

O serviço de integridade do Gerenciador de operações não processa arquivos de configuração e registra o evento 7022 de identificações e 1220

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Depois de instalar o agente do Microsoft System Center Operations Manager em um controlador de domínio do Windows, o serviço de integridade não processa arquivos de configuração. Além disso, eventos semelhantes aos seguintes são registrados no log de aplicativo no controlador de domínio a cada 30 minutos:

Evento 1

Tipo de evento: erro
Origem do evento: HealthService
Categoria do evento: Serviço de saúde
Identificação de evento: 7022
Data: Data
Tempo: Tempo
Usuário: n / a
Computador: Nome_do_computador
Descrição: O serviço de saúde baixou configuração segura do grupo de gerenciamento Management_Group_Name, e a configuração de processamento falhou com erro código 0x80FF003F(0x80FF003F).

Evento 2

Tipo de evento: erro
Origem do evento: HealthService
Categoria do evento: Serviço de saúde
Identificação de evento: 1220
Data: Data
Tempo: Tempo
Usuário: n / a
Computador: Nome_do_computador
Descrição: Configuração recebida não pode ser processada. Grupo de gerenciamento" Management_Group_Name".

Causa

Esse problema ocorre quando você configura uma conta não tem direitos administrativos como a conta de ação padrão.

O agente do System Center Operations Manager usa o perfil executar como denominado conta de monitoramento privilegiada para processar a configuração do serviço de saúde. Por padrão, o perfil da conta de monitoramento privilegiada usa a conta Sistema Local.

Ao configurar o agente para usar um usuário de domínio como a conta de ação padrão em um controlador de domínio, a ferramenta de bloqueio do serviço de integridade (HSLockdown.exe) é executada automaticamente na instalação. A ferramenta de bloqueio do serviço de saúde nega acesso a serviços de saúde para o objeto de segurança NT AUTHORITY\SYSTEM.

Nesse cenário, apenas o NT \ usuários entidade de segurança é permitido o acesso ao serviço de saúde. Mas quando o Active Directory está protegido, ou o agente está configurado incorretamente, não é possível autenticar a conta Sistema Local por meio do objeto de segurança usuários autenticados, portanto o agente não pode processar as informações de configuração do serviço de saúde.

Resolução

Para resolver esse problema, use um dos seguintes métodos.

Método 1: Configurar o perfil da conta de monitoramento privilegiada

Configurar o perfil de conta de monitoramento privilegiada para usar um usuário de domínio que tenha direitos administrativos sobre o controladores de domínio afetados. Para fazer isso, siga estas etapas:
  1. Abra o Console do SCOM e clique emAdministração.
  2. Em Segurança, com o botão direito Executar como contase clique em Criar executar como Conta. Isso inicia o assistente executado como conta para criar.
  3. Selecione Windows no Tipo de conta executar como caixa. Digite um nome para exibição e clique em Avançar.
  4. Digite o nome de usuário e a senha para uma conta que seja membro da Os administradores de grupo no controlador de domínio em clique em Criar.
  5. Depois de executar como é criada a conta, abra o Executar como perfis modo de exibição, e Clique duas vezes Conta de monitoramento privilegiada.
  6. Clique no Executar como contas guia.
  7. Clique em Novo.
  8. Clique o executar como conta que você criou na etapa 2 até a etapa 4.
  9. Clique no controlador de domínio na lista de computadores e clique em OK.
  10. Repita as etapas 7 a 9 para cada controlador de domínio afetado.
  11. Clique em OK no Executar como propriedades de perfil caixa de diálogo.
  12. Reinicie o serviço de integridade do OpsMgr nos controladores de domínio afetado.

Método 2: Executar HSLockdown.exe para configurar permissões

Execute HSLockdown.exe em controladores de domínio afetados para remover NT Authority\SYSTEM lista negado. Para fazer isso, siga estas etapas:
  1. No controlador de domínio, abra um prompt de comando e, em seguida, abra a pasta onde está instalado o software do agente.
  2. Digite o seguinte comando e pressione ENTER:
    hslockdown"Management_Group _Name"/R"NT AUTHORITY\SYSTEM"
    Neste comando, Management_Group _Name é o nome do grupo de gerenciamento do Operations Manager 2007 do qual o agente é membro. Use aspas se o nome contém espaços.
  3. Reinicie o serviço de integridade do OpsMgr.
  4. Repita as etapas 1 a 3 em cada controlador de domínio afetado.

Referências

Para obter mais informações sobre HSLockdown.exe, visite o seguinte site da Microsoft TechNet:
http://technet.microsoft.com/en-us/library/bb309542.aspx (http://technet.microsoft.com/en-us/library/bb309542.aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft System Center Operations Manager 2007
  • Microsoft System Center Operations Manager 2012
  • Microsoft System Center Operations Manager 2007 R2
  • Microsoft System Center Operations Manager 2007 Service Pack 1
Palavras-chave: 
kbexpertiseadvanced kbtshoot kbopmaninstall kbconfiguration kbeventlog kbevent kbmt KB946428 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 946428  (http://support.microsoft.com/kb/946428/en-us/ )