Article ID: 946495 - Last Review: January 14, 2008 - Revision: 1.2

You cannot set the MaxInactivityTimeDeviceLock parameter in Microsoft Solution for Hosted Messaging and Collaboration 4.0

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SYMPTOMS

In Microsoft Solution for Hosted Messaging and Collaboration 4.0, you try to define a value for the MaxInactivityTimeDeviceLock parameter when you call one of the following procedures:
  • The NewActiveSyncMailboxPolicy procedure in the Hosted Mobility 2007 namespace
  • The SetActiveSyncMailboxPolicy procedure in the Exchange 2007 Mobility Provider namespace
However, the procedure cannot run successfully. Additionally, you may receive an error message that resembles one of the following:
  • Error message 1
    The 'http://provisioning.microsoft.com/exchange2007mobilityprovider:maxInactivityTimeDeviceLock' element is invalid - The value '00:20:00' is invalid according to its datatype 'http://provisioning.microsoft.com/exchange2007mobilityprovider:unlimited' - The Pattern constraint failed." code="0x80131600" executeSeqNo="128".
  • Error message 2
    <response>
    <errorContext description="Cannot bind parameter 'MaxInactivityTimeDeviceLock' to the target. Exception setting &quot;MaxInactivityTimeDeviceLock&quot;: &quot;MaxInactivityTimeDeviceLock(1.00:00:00) is out of range: [00:01:00,01:00:00].&quot;" code="0x80131600" executeSeqNo="94">
    <errorSource namespace="Exchange 2007 Mobility Provider" procedure="SetActiveSyncMailboxPolicy" />
    <errorSource namespace="Managed Mobility 2007" procedure="SetActiveSyncMailboxPolicy" />
    <errorSource namespace="Hosted Mobility 2007" procedure="SetActiveSyncMailboxPolicy" />
    </errorContext>
    </response>

CAUSE

This problem occurs because of an error in the parsing of the time parameter in the Exchange 2007 Mobility Provider.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

To resolve this problem, apply this hotfix. To do this, follow these steps:
  1. On the server that is running Microsoft Provisioning Server (MPS), stop the MPS services to make sure that no more requests can be performed on the server. To do this, follow these steps:
    1. Click Start, click All Programs, click Administrative Tools, and then click Component Services.
    2. Expand Component Services, expand Computers, expand My Computer, expand COM+ Applications, right-click Provisioning Engine, click Disable, and then click Shut down.
  2. Start the MPS Deployment Tool.
  3. Expand Hosted Exchange, and then expand Exchange Provisioning.
  4. Right-click Exchange 2007 Mobility Provider, and then click Uninstall.
  5. Click Start Deployment.
  6. Open the C:\MSIShare folder.
  7. Change the name of the Exchange2007mobilityprovider.msi file to Exchange2007mobilityprovider_Orig.msi.
  8. Copy the new Exchange2007mobilityprovider.msi file from the hotfix to the MSIShare folder.
  9. In the MPS Deployment Tool, right-click Exchange 2007 Mobility Provider, click Install, and then click Start Deployment.
  10. In Component Services, right-click Provisioning Engine, and then click Enable and Start to restart the MPS engine.

Prerequisites

Microsoft Solution for Hosted Messaging and Collaboration 4.0 must be installed before you apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Interop.mpfproviderlib.dll1.0.0.014,49627-Nov-200703:01x86
Interop.msxml3.dll3.0.0.0141,47227-Nov-200703:02x86
Managedbase2.dll1.0.0.047,26427-Nov-200703:02x86
Exchange2007mobilityprovider.dll4.0.460.45131,07227-Nov-200702:59x86
Exchange2007mobilityprovider_ns.xmlNot applicable38,85827-Nov-200703:00Not applicable
Clearactivesyncdevice.xmlNot applicable61127-Nov-200702:59Not applicable
Getactivesyncdevicestatistics.xmlNot applicable73027-Nov-200702:59Not applicable
Getactivesyncmailboxpolicy.xmlNot applicable72727-Nov-200702:59Not applicable
Newactivesyncmailboxpolicy.xmlNot applicable1,64527-Nov-200702:59Not applicable
Removeactivesyncdevice.xmlNot applicable61227-Nov-200702:59Not applicable
Removeactivesyncmailboxpolicy.xmlNot applicable70027-Nov-200702:59Not applicable
Setactivesyncmailboxpolicy.xmlNot applicable1,75627-Nov-200702:59Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Keywords: 
kbautohotfix kbexpertiseinter kbqfe kbhotfixserver KB946495
 

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