Article ID: 946543 - Last Review: January 28, 2008 - Revision: 2.0

Error message when you upgrade Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0: "Unable to resolve related entity for report upgrade"

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SYMPTOMS

When you delete a custom entity that has a linked report in Microsoft Dynamics CRM 3.0, and then you upgrade Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0, you receive the following error message in the CRM40Setup.log file:
Time| Error| Unable to resolve related entity for report upgrade. The entity may have been added then deleted without updating the report reference.
Report name: Activities Due, Entity logical name: activity
Time| Error| Unable to upgrade reports.System.NullReferenceException: Object reference not set to an instance of an object.
at Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.BuildRelatedEntitiesValue(String reportName, String relatedEntitiesXml, Guid organizationId)
at Microsoft.Crm.Reporting.ReportUpgradeServer.GetReportProperties(String reportName, String organizationName, Guid organizationId)
at Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.LoadReportProperties(ReportUpgradeServer reportUpgradeServer, Hashtable propertiesByName, String organizationName, Guid organizationId, String reportingGroup)
at Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.LoadReports(ReportUpgradeServer reportUpgradeServer, String organizationName, Guid organizationId, String reportingGroup)
at Microsoft.Crm.Setup.Server.Utility.ReportUpgradeUtility.UpgradeReportsFromVersion3(String organizationUniqueName, String organizationFriendlyName, String reportingGroup, Int32 languageCode, InstallInfo installInfo, IProgressEventSource progress)
at Microsoft.Crm.Setup.Server.RSUpgradeAction.Do(IDictionary parameters)

CAUSE

This problem occurs because a report is linked to an entity that does not exist.

RESOLUTION

To resolve this problem, manually upload the Microsoft Dynamics CRM 3.0 report that causes the problem after you upgrade to Microsoft Dynamics CRM 4.0. To do this, follow these steps:
  1. Click Workplace, click Reports, and then click New.
  2. In the Report Type list, click Existing File.
  3. Click Browse.
  4. Click the .rdl file for the report that causes the problem, and then click Open.
  5. Complete the required fields, and then click Save and Close.

APPLIES TO
  • Microsoft Dynamics CRM 4.0
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