Message d'erreur lorsque vous exécutez un rapport dans Microsoft Dynamics CRM 4.0: «rapport d'erreur. Impossible d'afficher le rapport»

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Numéro d'article: 946585 - Voir les produits auxquels s'applique cet article
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Symptômes

Lorsque vous exécutez un rapport dans Microsoft Dynamics CRM 4.0, vous recevez le message d'erreur suivantes :
Création de rapports d'erreur. Le rapport ne peut pas être affiché.
En outre, l'événement suivant est enregistré dans le fichier journal du serveur rapport :
w3wp! traitement! 5! 12/10/2007-15 : 06 : 18:: e erreur : levée
Microsoft.ReportingServices.ReportProcessing.ReportProcessingException : Impossible de créer une connexion à la source de données 'CRM'.
Info : Microsoft.ReportingServices.ReportProcessing.ReportProcessingException : Impossible de créer une connexion à la source de données 'CRM'. ---> System.Data.SqlClient.SqlException : Impossible d'ouvrir la base de données «MSCRM_CONFIG», demandée par la connexion. La connexion a échoué.
Échec de la connexion de l'utilisateur < espace Réservé pour l'authentification de compte >.

Cause

Ce problème produit car le compte que le connecteur de données Microsoft Dynamics CRM pour Microsoft SQL Server Reporting Services est à l'aide de à authenticatene dispose pas des autorisations de pour les bases de données Microsoft CRM.

Résolution

Pour résoudre ce problème, accorder l'autorisation de compte appropriées pour accéder aux bases de données Microsoft Dynamics CRM. Pour ce faire, procédez comme suit :
  1. Identifier le compte est utilisé par le connecteur de données Microsoft Dynamics CRM pour Microsoft SQL Server qui authentifie à Microsoft SQLServer .

    Pour Microsoft SQL Reporting Services 2005

    Si le connecteur de données Microsoft Dynamics CRM pour Microsoft SQL Server Reporting Services est installé sur une instance de SQL Reporting Services 2005, le connecteur de données Microsoft Dynamics CRM pour Microsoft SQL Server Reporting Services s'authentifient auprès de SQL Server en tant qu'identité de l'Internet Information Services (IIS ) pool d'applications utilisé par SQL Reporting Services. Pour déterminer l'identité du pool d'applications IIS utilisé par SQL Reporting Services, procédez comme suit :
    1. Sur le serveur Microsoft SQL Reporting Services, cliquez sur le bouton Démarrer, et puis point à Tous les programmes, cliquez sur Microsoft SQL Server 2005, cliquez sur Outils de configuration, puis cliquez sur Configuration de Reporting Services.
    2. Dans le rapport de sélection de l'instance d'installation de Server, sélectionnez l'instance de SQL Reporting Services dans lequel le connecteur de données Microsoft CRM pour Microsoft SQL Server Reporting Services est installé, puis cliquez sur se connecter.
    3. Cliquez sur identification de Service Web. Notez la valeur de compte de service ASP.NET. Cette valeur indique quel compte est utilisé pour les services Internet (IIS) pool d'applications utilisé par SQL Reporting Services qui est également le compte est utilisé par le connecteur de données Microsoft Dynamics CRM pour Microsoft SQL Server Reporting Services lors de l'authentification à SQL Server .

    Pour SQL Reporting Services 2008

    Si le connecteur de données Microsoft Dynamics CRM pour Microsoft SQL Server Reporting Services est installé sur une instance de SQL Reporting Services 2008, il s'authentifient auprès de SQL Server que le compte exécutant le service SQL Server Reporting Services Windows. Pour déterminer le compte qui exécute SQL Server Reporting service Services Windows, procédez comme suit :
    1. Sur le serveur Microsoft SQL Reporting Services, cliquez sur le bouton Démarrer, puis pointez sur Outils d'administrationet puis cliquez sur Services.
    2. Recherchez le service SQL Server Reporting Services et notez la valeur est répertoriés dans la colonne Ouvrir une session en tant que.
  2. Accorder l'autorisation de compte approprié pour accéder aux bases de données Microsoft Dynamics CRM.
    J'ai f SQL Reporting Services et la version de SQL Server bases de données sont installées sur le même serveur et le compte identifié dans s Step 1 est Service réseau , procédez comme suit :
    1. Démarrez SQL Server Management Studio. Pour ce faire, cliquez sur le bouton Démarrer, et puis point pour Tous les programmes, pointez sur Microsoft SQL Server 2005, puis cliquez sur SQL Server Management Studio.
    2. Développez sécurité, développez connexions, cliquez avec le bouton droit sur Autorité NT\Service réseau, puis cliquez sur Propriétés.
    3. Cliquez sur mappages utilisateur.
    4. Activez la case à cocher Organization_name _MSCRM, puis activez la case à cocher public et la case à cocher CRMReaderRole.

      Remarque L'espace réservé Organization_name est un espace réservé pour le nom de l'organisation réel.
    5. Activez la case à cocher MSCRM_Config, puis activez la case à cocher public et la case à cocher CRMReaderRole.
    6. Cliquez sur OK.


    J'ai f SQL Reporting Services et les bases de données SQL sont installés sur le même serveur et le compte identifié dans s Step 1 est LocalSystem , procédez comme suit :
    1. Démarrez SQL Server Management Studio. Pour ce faire, cliquez sur sur le bouton Démarrer, et puis point pour Tous les programmes, pointez sur Microsoft SQL Server 2005, puis cliquez sur SQL Server Management Studio.
    2. Développez sécurité, développez connexions, cliquez avec le bouton droit sur Autorité NT\SYSTÈME et puis cliquez sur Propriétés.
    3. Cliquez sur mappages utilisateur.
    4. Activez la case à cocher Organization_name _MSCRM, puis activez la case à cocher public et la case à cocher CRMReaderRole.

      Remarque L'espace réservé Organization_name est un espace réservé pour le nom de l'organisation réel.
    5. Activez la case à cocher MSCRM_Config, puis activez la case à cocher public et la case à cocher CRMReaderRole.
    6. Cliquez sur OK.


    J'ai f SQL Reporting Services et la version de SQL Server bases de données sont installées sur des serveurs distincts et le compte identifié dans s Step 1 est Service réseau ou système local , procédez comme suit :
    1. a. Ouvrez Utilisateurs et ordinateurs et vérifiez que le compte d'ordinateur SQL Reporting Services est un membre de SQLAccessGroup qui a été créé par l'installation de Microsoft Dynamics CRM.
    2. Démarrez SQL Server Management Studio. Pour ce faire, cliquez sur sur le bouton Démarrer, et puis point pour Tous les programmes, pointez sur Microsoft SQL Server 2005, puis cliquez sur SQL Server Management Studio.
    3. Développez sécurité, développez connexions, cliquez avec le bouton droit sur connexions SQLAccessGroup et puis cliquez sur Propriétés.
    4. Cliquez sur mappages utilisateur.
    5. Activez la case à cocher Organization_name _MSCRM, puis activez la case à cocher public et la case à cocher CRMReaderRole.

      Remarque L'espace réservé Organization_name est un espace réservé pour le nom de l'organisation réel.
    6. Activez la case à cocher MSCRM_Config, puis activez la case à cocher public et la case à cocher CRMReaderRole.
    7. Cliquez sur OK.


    Effectuez les étapes suivantes si SQL Reporting Services s'exécute comme un compte d'utilisateur de domaine :
    1. Ouvrez Utilisateurs et ordinateurs et vérifiez que le compte d'utilisateur identifié à l'étape 1 est un membre de SQLAccessGroup qui a été créé par l'installation de Microsoft Dynamics CRM.
    2. Démarrez SQL Server Management Studio. Pour ce faire, cliquez sur Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server 2005, puis cliquez sur SQL Server Management Studio.
    3. Développez sécurité, développez connexions, cliquez avec le bouton droit sur connexions SQLAccessGroup et puis cliquez sur Propriétés.
    4. Cliquez sur mappages utilisateur.
    5. Activez la case à cocher Organization_name _MSCRM, puis activez la case à cocher public et la case à cocher CRMReaderRole.

      Remarque L'espace réservé Organization_name est un espace réservé pour le nom de l'organisation réel.
    6. Activez la case à cocher MSCRM_Config, puis activez la case à cocher public et la case à cocher CRMReaderRole.
    7. Cliquez sur OK.

Références

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
946289Message d'erreur lorsque vous exécutez un rapport dans Microsoft Dynamics CRM 4.0: «Impossible d'afficher le rapport»

Propriétés

Numéro d'article: 946585 - Dernière mise à jour: mardi 8 septembre 2009 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Dynamics CRM 4.0
Mots-clés : 
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La version anglaise de cet article est la suivante: 946585
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