Some Secure Digital (SD) cards do not work correctly on Windows XP-based computers

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Article ID: 946629 - View products that this article applies to.
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Symptoms

Some Secure Digital (SD) cards do not work correctly on Windows XP-based computers. Additionally, you may notice a yellow exclamation mark (!) next to the SD card in Device Manager.

This problem may occur even though you have applied other hotfixes that are required for high-capacity SD card support. For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
923293 The 923293 hotfix adds support for SD High Capacity memory cards in Windows XP
934428 Hotfix for Windows XP that adds support for SDHC cards that have a capacity of more than 4 GB

Cause

This problem occurs because a defect in Windows XP prevents the native SD driver from being initialized correctly.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatformSP requirement
Sdbus.sys6.0.4069.328078,72024-Dec-200709:27x86SP2
Sffdisk.sys6.0.4069.328012,03224-Dec-200709:20x86SP2
Sffp_mmc.sys6.0.4069.328010,24024-Dec-200709:20x86SP2
Sffp_sd.sys6.0.4069.328011,00824-Dec-200709:20x86SP2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about a similar problem that occurs in Windows Vista, click the following article number to view the article in the Microsoft Knowledge Base:
939772 Some Secure Digital (SD) cards may not be recognized in Windows Vista
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 946629 - Last Review: June 21, 2014 - Revision: 1.0
Applies to
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbwinxppresp3fix kbbug kbfix kbqfe KB946629

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