Article ID: 946697 - Last Review: December 21, 2007 - Revision: 1.1

Event ID 36865 is logged after you unpack a site to a clean installation of Commerce Server 2007 Service Pack 1

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario. You unpack the starter site or other sites to a clean installation of Microsoft Commerce Server 2007 Service Pack 1 (SP1). In this scenario, an event that resembles the following is logged in the Application log:

Date: <Date>
Time: <Time>
Type: Error
User: N/A
Computer: <ComputerName>
Source: Commerce Server
Category: None
Event ID: 36865
Description:
Error in Commerce Administration Object : Description - 'The following resources are old. They will not function correctly until they are upgraded:
Product Catalog (7.2.0)
Marketing (7.1.0)
Please run the migration tool in order to upgrade them to the latest versions.

Note When you run the Commerce Server 2007 Upgrade Wizard, the Upgrade Wizard shows that all site resources are current and are the correct versions.

CAUSE

This problem occurs when a new installation of Commerce Server 2007 is built, and Commerce Server 2007 SP1 is installed before any site is unpacked on the server. Because no sites have been configured, certain updates to the MSCS_Admin database are not performed.

RESOLUTION

To resolve this problem, run the CSConfig.exe command to update the MSCS_Admin database. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. For 32-bit editions of Commerce Server 2007, type cd "%ProgramFiles%\Microsoft Commerce Server 2007", and then press ENTER. For 64-bit editions of Commerce Server 2007, type cd "%ProgramFiles(x86)%\Microsoft Commerce Server 2007", and then press ENTER.
  3. Type csconfig.exe /r Feature.MS.CS.Admin, and then press ENTER.
  4. In the Microsoft Commerce Server Configuration dialog box, click Next.
  5. On the Administration Database page, enter the correct database information for the MSCS_Admin database, and then click Next.
  6. On the Summary page, review the summary information, and then click Next.
  7. Click Finish when the configuration has finished.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If sites are already configured before Commerce Server 2007 SP1 is installed, this problem will not occur.

Steps to reproduce this problem

  1. Install Commerce Server 2007 on a computer that is running Windows Server 2003 and that is up to date.
  2. Run the Commerce Server 2007 Configuration Wizard to configure the MSCS_Admin database and other selected features.

    For more information about how to use the Commerce Server 2007 Configuration Wizard, visit the following Microsoft Developer Network (MSDN) Web site:
    http://msdn2.microsoft.com/en-us/library/aa546004.aspx (http://msdn2.microsoft.com/en-us/library/aa546004.aspx)
  3. Install Commerce Server 2007 SP1.
  4. Unpack the Commerce Server 2007 starter site.

    For more information about how to unpack a site in Commerce Server 2007, visit the following MSDN Web site:
    http://msdn2.microsoft.com/en-us/library/aa544681.aspx (http://msdn2.microsoft.com/en-us/library/aa544681.aspx)
    When you try to use the starter site, the problem that is described in the "Symptoms" section occurs.

REFERENCES

For more information about the Commerce Server 2007 Upgrade Wizard, visit the following MSDN Web site:
http://msdn2.microsoft.com/en-us/library/ms942138.aspx (http://msdn2.microsoft.com/en-us/library/ms942138.aspx)

APPLIES TO
  • Microsoft Commerce Server 2007 Enterprise Edition
  • Microsoft Commerce Server 2007 Developer Edition
  • Microsoft Commerce Server 2007 Standard Edition
  • Microsoft Commerce Server 2007 Service Pack 1
Keywords: 
kbexpertiseadvanced kbtshoot kberrmsg kbpubtypekc kbprb KB946697
 

Article Translations

 

Related Support Centers