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FIX: Some files may not be visible in Source Control Explorer after you perform some operations in Visual Studio 2005 Team Foundation Server Service Pack 1

Article ID:946925
Last Review:April 9, 2008
Revision:1.3
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SYMPTOMS

After you perform some operations in Microsoft Visual Studio 2005 Team Foundation Server Service Pack 1, some files may not be visible in Source Control Explorer.

Consider the following example. A solution that is added to source control has the following characteristics:
Project A contains Folder A and Folder B.
Folder A contains File A and File B.
File A and File B are checked out.
Project B contains some folders.
In Source Control Explorer, you follow these steps:
1.You move Folder A from Project A to Project B and then rename Folder A.
2.You make some changes to File A and to File B and then check in the changes.
In this example, if you check out Project B and then examine the contents in the change set, File A and File B are changed successfully. However, File A and File B cannot be found in Source Control Explorer.

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CAUSE

This problem occurs because some files continue to reference the old parent folder in the old project after you move a folder across projects and then rename the folder.

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RESOLUTION

Hotfix information



A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft Web site:
http://code.msdn.microsoft.com/KB946925 (http://code.msdn.microsoft.com/KB946925)

Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Prerequisites

You must have Visual Studio 2005 Team Foundation Server Service Pack 1 installed to apply this hotfix. This hotfix replaces a SQL Server stored procedure. If you installed Visual Studio 2005 Team System on a dual server, you must apply this hotfix on the data tier server. If you installed Visual Studio 2005 Team System on a single server, you must apply this hotfix on the server that is running Visual Studio 2005 Team Foundation Server.

Restart information

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

This hotfix does not change any files. This hotfix changes only a SQL Server stored procedure.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Visual Studio 2005 Team Foundation Server

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Keywords: 
kbexpertiseadvanced kbfix kbpubtypekc kbqfe KB946925

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