[FIX ファイルが表示されないソース管理エクスプローラーで Visual Studio 2005 Team Foundation Server Service Pack 1 でいくつかの操作を実行した後ことがあります。

文書翻訳 文書翻訳
文書番号: 946925 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

いくつかの操作を Microsoft Visual Studio 2005 Team Foundation Server Service Pack 1 で実行すると、いくつかのファイルがソース管理エクスプローラーで表示されません。

例を考えてみます。 ソース管理に追加するソリューションは、次特性を持ちます。
  • フォルダー、およびフォルダー B. にプロジェクト A が含まれます
  • フォルダー、ファイル A と B. のファイルが含まれます
  • ファイル A と B のファイルはチェックアウトをされています。
  • プロジェクト B にはいくつかのフォルダーが含まれます。
次のソース管理エクスプローラーでする手順に従います。
  1. プロジェクト B にプロジェクト A からフォルダー A を移動し、A. フォルダー名を変更します。
  2. ファイル、ファイル B をいくつか変更して、変更をチェックインします。
正常この例では、プロジェクト B のチェックアウトし、変更セットの内容を調べてファイル A と B のファイルに変更します。 ただし、ファイル A と B のファイルが見つかりませんソース管理エクスプローラーで。

原因

この問題はいくつかのファイル引き続きプロジェクト間でフォルダーを移動し、そのフォルダーの名前を変更した後、古いプロジェクトで古い親フォルダーを参照するために発生します。

解決方法

修正プログラムについて



サポートされている修正プログラムが Microsoft から提供されています。 ただし、ことを目的としたこの修正プログラムものですこの資料に記載されている問題のみを修正します。 この修正プログラムのみシステムに適用この特定の問題が発生しています。 この修正プログラム テストを受ける可能性があります。 そのため場合この問題で深刻な影響を受けていないお勧めしますこの修正プログラムを含む、次回ソフトウェアの更新されるまで待つことです。

MSDN コード ギャラリーからこの修正プログラムをダウンロードするには、次のマイクロソフト Web サイトを参照してください。
http://code.msdn.microsoft.com/KB946925

メモ MSDN コード ギャラリーは、修正プログラムが利用する言語を表示します。 表示されている言語が表示されない場合コード ギャラリー リソース] ページがその言語の使用できないためにが。

メモ 追加問題が発生する場合は、個別のサービス要求を作成した任意のトラブルシューティングが必要な場合。 通常のサポート料金が追加の質問およびこの特定の修正プログラムの対象とならない問題について適用されます。 一覧については、完了マイクロソフト カスタマーサービス & サポートの電話番号のまたは個別のサービス要求を作成する、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support

前提条件

Visual Studio 2005 Team Foundation Server Service Pack 1 インストールこの修正プログラムを適用する必要があります。 この修正プログラム、SQL Server のストアド プロシージャが置き換えられます。 デュアル サーバー上で Visual Studio 2005 Team System をインストールする場合この修正プログラム、データ層サーバーを適用する必要があります。 1 台のサーバーをインストールした Visual Studio 2005 Team System は場合、この修正プログラム Visual Studio 2005 Team Foundation Server を実行しているサーバーに適用する必要があります。

再起動について

この修正プログラムを適用した後、コンピューターを再起動する必要はありません。

修正プログラム置き換えに関する情報

修正この修正プログラムはプログラム置き換えられることもほかありません。

ファイル情報

この修正プログラムには、すべてのファイルは変わりません。 この修正プログラムの変更のみ、SQL Server ストアド プロシージャです。

状況

マイクロソフトとして認識していますこの問題を記載されているいるマイクロソフト製品の問題。

詳細

ソフトウェア更新の用語についてについては、資料の「サポート技術情報」(Microsoft Knowledge Base) を表示する次の資料番号をクリック。
824684マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

プロパティ

文書番号: 946925 - 最終更新日: 2008年4月9日 - リビジョン: 1.3
この資料は以下の製品について記述したものです。
  • Microsoft Visual Studio 2005 Team Foundation Server
キーワード:?
kbfix kbqfe kbpubtypekc kbexpertiseadvanced kbmt KB946925 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:946925
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com