Article ID: 947005 - Last Review: December 10, 2008 - Revision: 2.0

You cannot rebuild or replicate offline address books in Hosted Messaging and Collaboration 4.0 Migration Kit

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SYMPTOMS

In Microsoft Solution for Hosted Messaging and Collaboration 4.0 Migration Kit, you import offline address books by using the Import::ImportOfflineAddressBook procedure. When you do this, you cannot rebuild or replicate the offline address books.

Additionally, the following events are logged in the Application log on the server that is hosting the offline address books:

Event Type: Error
Event Source: MSExchangeIS Public Store
Event Category: Replication Site Folders
Event ID: 3048
Description: Error -1605 occurred while creating site folder (4a-8) NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\/o=ExchnageOrganization/cn=addrlists/cn=oabs/cn=<guid or name of oab>.

Event Type: Error
Event Source: MSExchangeIS Public Store
Event Category: Replication Site Folders
Event ID: 3043
Description: Error 0xfffff9bb occurred while performing a site folder check for Public Folder Store "First Storage Group\Public Folder Database".

Note This situation affects environments in which Microsoft Solution for Hosted Messaging and Collaboration 3.5 is being migrated to Hosted Messaging and Collaboration 4.0 Migration Kit and in which public folders are being replicated.

CAUSE

This problem occurs because the Import::ImportOfflineAddressBook procedure assigns duplicate SiteFolderGuid attributes to offline address books.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Hosted Messaging and Collaboration 4.0 Migration Kit installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

However, you have to stop and then restart the Microsoft Provisioning Server (MPS) Provisioning Engine COM+ application by using the Component Services console.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Hostedemail2007import_ns.xmlNot applicable134,83203-Jan-200805:42Not applicable
Importmailbox.xmlNot applicable64803-Jan-200805:42Not applicable
Importofflineaddressbook.xmlNot applicable60403-Jan-200805:42Not applicable
Importrootpublicfolder.xmlNot applicable71603-Jan-200805:42Not applicable
Importsmtpdomains.xmlNot applicable63403-Jan-200805:42Not applicable

How to apply the hotfix

To apply this hotfix, log on as a domain and local administrator, and then follow these steps on all the MPS Engine servers:
  1. Uninstall the old namespace. To do this, follow these steps:
    1. From the location where Hosted Messaging and Collaboration version 4.0 Migration Kit is located, run the HostedEmail2007ImportNS.msi file.
    2. Click Next.
    3. Click Remove, and then click Next.
    4. Click Remove again.
  2. Apply the hotfix. To do this, follow these steps:
    1. Rename the old HostedEmail2007ImportNS.msi file as follows:
      HostedEmail2007ImportNS-old.msi
    2. Run the HostedEmail2007ImportNS.msi file, and then follow the Setup wizard to complete the installation.
    3. On the MPS Engine servers, start Component Services.
    4. Expand Component Services, expand Computers, and then expand My Computer.
    5. Click COM+ Applications.
    6. Right-click Provisioning Engine, and then click Shut Down.
After you apply the hotfix, the new version of the HostedEmail2007Import namespace is 4.1.49.1. To verify this, follow these steps:
  1. Open the HostedEmail2007Import_Ns.xml file in Notepad or in Windows Internet Explorer.

    Note The HostedEmail2007Import_Ns.xml file is in the following location:
    Drive:\Program Files\Microsoft Hosting\Provisioning\Hosted Email 2007 Import\
  2. Under the disclaimer at the top, locate the following text:
    namespace name=Hosted Email 2007 Import" version="4.1.49.1"

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Keywords: 
kbautohotfix kbexpertiseadvanced kbbug kbfix kbhotfixserver kbqfe KB947005