Message d'erreur lorsque vous utilisez Microsoft Dynamics CRM E-mail Router: « Le paramètre de configuration du service E-mail Router "EmailUser" est manquant »

Traductions disponibles Traductions disponibles
Numéro d'article: 947094 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous utilisez Microsoft Dynamics CRM E-mail Router, vous risquez de rencontrer au moins un des problèmes suivants.

Problème 1

Lorsque vous utilisez Microsoft Dynamics CRM E-mail Router sur un ordinateur, l'événement suivant est consigné dans le journal des applications :

Type d'événement : erreur
Source de l'événement : MSCRMEmail
Catégorie de l'événement : Aucune
ID d'événement : 0
Date : Date
Heure : Heure
Utilisateur : Non applicable
Ordinateur : Ordinateur_routeur
Description :
# 52311 - Le service E-mail Router ne peut pas créer une instance d'un fournisseur de services à l'aide de l'assembly : Microsoft.Crm.Tools.EmailProviders.dll et de la classe : Microsoft.Crm.Tools.Email.Providers.Pop3PollingMailboxProvider. System.Configuration.ConfigurationErrorsException : Le paramètre de configuration du service E-mail Router « EmailUser » est manquant. Ce paramètre est requis.
at Microsoft.Crm.Tools.Email.Providers.ConfigNodeReader.GetCheckedStringValue(String elementName, String defaultValue, Boolean throwIfMissing, Boolean hide)
at Microsoft.Crm.Tools.Email.Providers.Pop3PollingMailboxProvider.get_EmailUser()
at Microsoft.Crm.Tools.Email.Providers.Pop3PollingMailboxProvider.get_IdentityHash()
at Microsoft.Crm.Tools.Email.Providers.ProviderBuilder.BuildProvider(ProviderConfiguration providerConfiguration, ServiceLogger serviceLoggerToUse, ManualResetEvent shutdownEvent, SystemState systemState, Boolean throwOnError)

Problème 2

Lorsque vous utilisez la fonctionnalité Tester l'accès dans le gestionnaire de configuration du courrier électronique de Microsoft Dynamics CRM, le message d'erreur suivant s'affiche :
Statut entrant : Échec - Le paramètre de configuration du service E-mail Router « EmailUser » est manquant. Ce paramètre est requis.

Cause

Ce problème se produit car Microsoft Dynamics CRM n'est pas configuré de manière à utiliser vos informations d'identification pour envoyer et recevoir des messages électroniques. Par conséquent, Microsoft Dynamics CRM E-mail Router ne dispose ni du nom d'utilisateur ni du mot de passe permettant de récupérer le courrier.

Résolution

Pour résoudre ce problème, autorisez Microsoft Dynamics CRM à envoyer et recevoir du courrier électronique en votre nom. Pour cela, procédez comme suit :
  1. Démarrez le client Web Microsoft Dynamics CRM.
  2. Cliquez sur Outils, puis sur Options.
  3. Sous l'onglet Adresse de messagerie, activez la case à cocher Autoriser le routeur de messagerie à utiliser mes informations d'identification pour envoyer et recevoir des messages électroniques.
  4. Tapez le nom d'utilisateur et le mot de passe.
  5. Cliquez sur OK.

Propriétés

Numéro d'article: 947094 - Dernière mise à jour: lundi 12 septembre 2011 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Dynamics CRM 2011
  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics Live CRM Professional Edition
  • Microsoft Dynamics Live CRM Enterprise Edition
Mots-clés : 
kbfreshness2008 kbmbsemail kbmbscrmonline kberrmsg kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter KB947094
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com