REVISIÓN: Un proyecto de prueba de Visual Studio 2005 no funcione correctamente cuando se convierte mediante clic en el Asistente de conversión en Visual Studio 2008

Seleccione idioma Seleccione idioma
Id. de artículo: 947171 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando convierte un proyecto de prueba de Microsoft Visual Studio 2005 mediante clic en el Asistente para conversión de Visual Studio 2008, el proceso de conversión se completa correctamente. Sin embargo, el proyecto no funcione correctamente. Además, puede recibir un mensaje de error similar al siguiente:
<assembly>UTA059: La prueba DLL '<ensamblado>' se creó con Visual Studio 2005 y no se puede ejecutar.

Causa

Este problema se produce porque el Asistente de conversión no puede actualizar correctamente todos los archivos que tengan las siguientes extensiones de nombre de archivo:
  • .csproj
  • .vbproj
  • .vsmdi
  • testrunconfig
Cuando finalice el Asistente para conversión, el proyecto aún hace referencia a los archivos de versión de Visual Studio 2005 que tengan estas extensiones de nombre de archivo.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Este hotfix puede ser sometido a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, se recomienda que espere al próximo Service Pack que contenga este hotfix.

Para resolver este problema inmediatamente, póngase en contacto con servicios de soporte de cliente de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de los servicios de soporte técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Requisitos previos

Debe tener instalado para aplicar esta revisión de Visual Studio 2008.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para encontrar la diferencia entre la UTC y la hora local, utilice la zona horaria de ficha en la fecha y hora elemento Panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempo
Microsoft.VisualStudio.QualityTools.vsip.dll9.0.21022.55286,72029-Feb-19 de 200809: 03 a.m.
Microsoft.VisualStudio.QualityTools.Tips.TuipPackage.dll9.0.21022.55356,35229 19-Feb-200809: 32 am

Solución

Para evitar este problema, actualice manualmente los archivos de solución. Para ello, visite el siguiente sitio Web de Microsoft y siga los pasos que aparecen:
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2534717&SiteID=1

Propiedades

Id. de artículo: 947171 - Última revisión: jueves, 31 de julio de 2008 - Versión: 1.1
La información de este artículo se refiere a:
  • Microsoft Visual Studio 2008 Team Edition for Database Professionals
  • Microsoft Visual Studio 2008 Team Edition for Software Architects
  • Microsoft Visual Studio 2008 Team Edition for Software Developers
  • Microsoft Visual Studio 2008 Team Edition for Software Testers
Palabras clave: 
kbmt kbhotfixserver kbqfe kbexpertiseadvanced KB947171 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 947171

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com