CORRECTIF : un projet de test Visual Studio 2005 peut ne pas fonctionner correctement lorsque vous la convertissez en utilisant l'Assistant Conversion de Visual Studio 2008

Traductions disponibles Traductions disponibles
Numéro d'article: 947171 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous convertissez un projet de test Microsoft Visual Studio 2005 à l'aide de l'Assistant Conversion de Visual Studio 2008, le processus de conversion se termine correctement. Toutefois, le projet peut ne pas fonctionner correctement. En outre, un message d'erreur semblable au suivant peut s'afficher :
UTA059 : le test de DLL « <assembly> » a été créé à l'aide de Visual Studio 2005 et ne peut pas être exécutée.

Cause

Ce problème se produit parce que l'Assistant de conversion ne peut pas mettre correctement à niveau des fichiers qui portent les extensions de nom de fichier suivantes :
  • .csproj
  • .vbproj
  • .vsmdi
  • .testrunconfig
Une fois l'Assistant de conversion terminé, le projet fait référence toujours aux fichiers de version Visual Studio 2005 qui ont ces extensions de nom de fichier.

Résolution

Informations sur le correctif

Un correctif est désormais disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. S'il s'appliquent uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre le prochain service pack contenant ce correctif.

Pour résoudre ce problème immédiatement, contactez services de support technique Microsoft afin d'obtenir le correctif logiciel. Pour une liste complète des numéros de téléphone services de support technique Microsoft et des informations sur les frais engendrés, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note Dans certains cas, les frais aucuns de support peuvent être facturés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par la mise à jour en question.

Conditions préalables

Vous devez disposer de Visual Studio 2008 pour appliquer ce correctif.

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et heure locale, utilisez le fuseau horaire onglet dans la Date et heure élément dans le Panneau de configuration.
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeure
Microsoft.VisualStudio.QualityTools.vsip.dll9.0.21022.55286,72029 Février-19 200809:03am
Microsoft.VisualStudio.QualityTools.Tips.TuipPackage.dll9.0.21022.55356,35229 Février-19-200809:32am

Contournement

Pour contourner ce problème, mettez à manuellement jour les fichiers de solution. Pour cela, reportez-vous au site Web de Microsoft à adresse et suivez les étapes affichées il :
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2534717&SiteID=1

Propriétés

Numéro d'article: 947171 - Dernière mise à jour: jeudi 31 juillet 2008 - Version: 1.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Visual Studio 2008 Team Edition for Database Professionals
  • Microsoft Visual Studio 2008 Team Edition for Software Architects
  • Microsoft Visual Studio 2008 Team Edition for Software Developers
  • Microsoft Visual Studio 2008 Team Edition for Software Testers
Mots-clés : 
kbmt kbhotfixserver kbqfe kbexpertiseadvanced KB947171 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 947171
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com