I file di definizione del motore di analisi Kaspersky non sono aggiornati e 6012 ID di evento e 9874 vengono registrati in Antigen 9.0 per Exchange o Antigen 9.0 per SMTP Gateways

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Sintomi

In un computer che esegue Microsoft Antigen 9.0 per Exchange o Microsoft Antigen 9.0 per SMTP Gateways, si si verifichino dei seguenti sintomi:
  • Il Kaspersky scansione di definizione del modulo di gestione di file non vengono aggiornati alla versione più recente.
  • Nel registro dell'applicazione vengono registrati i seguenti eventi:

    ID evento 6012
    Tipo evento: errore
    Origine evento: GetEngineFiles
    Categoria evento: Errore del modulo
    ID evento: 6012
    Data: date
    Ora: time
    Utente: N/d
    Computer: ComputerName
    Descrizione: In Microsoft Forefront Server Security ha rilevato un errore durante l'aggiornamento del motore di analisi di esecuzione.
    Motore di analisi: Kaspersky5
    Codice di errore: 0x80070102
    Descrizione: Impossibile acquisire il mutex di aggiornamento del motore di analisi nel periodo di timeout designato.
    ID evento 9874
    Tipo evento: avviso
    Origine evento: MSExchangeIS
    Categoria evento: Virus Scanning
    ID evento: 9874
    Data: date
    Ora: time
    Utente: N/d
    Computer: ComputerName
    Descrizione: Errore imprevisto 0x8004010f durante "EcProcessVirusScanQueueItem" durante la ricerca di virus. Database delle cassette postali: / o = OrganizationName OU = / CN AdministrativeGroupName = Configuration/cn = Servers/cn = / cn ComputerName = ID della cartella Microsoft Private MDB: ID del messaggio 5-B32D0E 1D: 189-3783940435
  • Nel file ProgramLog.txt viene registrati le seguenti informazioni sull'errore:
    <date and time>(11340-15956),"INFORMATION: Forefront Server Security IS scanning subsystem has been taken offline." 
    <date and time>(11340-15956),"ERROR: The call to g_ppRealtimeProxies[-2147023170]->DisableScanEngine(dwEngine) from DisableScanEngines function failed and returned: fecdc9" 
    <date and time>(10872-15488),"ERROR: (0x800706be) The remote procedure call failed. Scan engine could not be updated. An error occurred while disabling scan jobs. hr = 0x800706BE." 
    <date and time>(10872-15488),"INFORMATION: The Kaspersky5 scan engine has been rolled back." 
    <date and time>(10872-15488),"INFORMATION: Sending Signature Update Failed Alert" 
    <date and time>( 6288-12416),"INFORMATION: Initializing virus scanning" 
    <date and time>(11340-15956),"INFORMATION: Forefront Server Security Monitor detected Information Store process started." 
    <date and time>(14080-16532),"INFORMATION: Attempting to download the Kaspersky5 scan engine package from http://<URL>." 
    <date and time>(14080-16532),"INFORMATION: The proxy settings will be used for this connection." 
    <date and time>(14080-16532),"INFORMATION: The Kaspersky5 scan engine has been downloaded" 
    <date and time>(14080-16532),"INFORMATION: The Kaspersky5 scan engine has been staged." 
    <date and time>( 1060-11880),"INFORMATION: Testing the Kaspersky5 scan engine." 
    <date and time>(14080-16532),"INFORMATION: The Kaspersky5 scan engine has been installed." 
    <date and time>(14080-16532),"INFORMATION: The Kaspersky5 scan engine has been updated from http://<URL>."
    Nota Il file ProgramLog.txt si trova nella cartella di installazione di Antigen.

Cause

Questo problema si verifica perché Antigen 9.0 non gestisce correttamente il motore di analisi Kaspersky aggiornato.

Kaspersky ha rilasciato un motore di analisi aggiornato. Il motore di analisi include un file di .Lock. Antigen non può gestire la gestione di tutti gli aggiornamenti se qualsiasi nome di file nell'aggiornamento inizia con un periodo. In questo scenario, quando tenta di eliminare gli aggiornamenti meno recenti quando gli aggiornamenti più recenti sono disponibili, Antigen Antigen in modo non corretto determina che qualsiasi nome di file che inizia con un punto è una directory. Di conseguenza, Antigen non elimina il file. Antigen per lasciare motore precedente cartelle di aggiornamento presente quando queste cartelle devono essere eliminate a causa di questo comportamento. Di conseguenza, Antigen non aggiorna il motore di analisi Kaspersky.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Per installare questo aggiornamento rapido (hotfix) non è richiesto alcun prerequisito.

Necessità di riavvio

Non è necessario riavviare il computer una volta applicato questo aggiornamento rapido (hotfix) se il processo di GetEngineFiles.exe non è in esecuzione quando si applica l'aggiornamento rapido.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix. L'hotfix descritto in questo articolo è Antigen 9.0 Service Pack 1 Rollup 2. Questo è l'aggiornamento rapido solo nel cumulativo. Le correzioni incluse in questo aggiornamento rapido (hotfix) sono cumulative. Di conseguenza, le correzioni per i rollup di aggiornamento rapido (hotfix) precedente per Antigen 9.0 Service Pack 1 sono incluse tutte in questo hotfix cumulativo.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Antigen 9.0 per Exchange con Service Pack 1 (SP1)
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Aexmladapter.dll9.1.1097.6515,58407-Gen-200817: 20x 86
Antigenasj.dll9.1.1097.6310,78407-Gen-200817: 20x 86
Antigenclient.exe9.1.1097.61,147,39207-Gen-200817: 20x 86
Antigeninternet.exe9.1.1097.6744,96007-Gen-200817: 20x 86
Antigenmanual.exe9.1.1097.6743,93607-Gen-200817: 20x 86
Antigenrealtime.exe9.1.1097.6724,99207-Gen-200817: 20x 86
Antigenservice.exe9.1.1097.61,385,98407-Gen-200817: 20x 86
Antigensmtpsink.dll9.1.1097.6418,81607-Gen-200817: 20x 86
Antigenvsapi.dll9.1.1097.6315.39207-Gen-200817: 20x 86
Getenginefiles.exe9.1.1097.6538,62407-Gen-200817: 20x 86
Sfxcab.exe9.1.1097.643.00807-Gen-200817: 20x 86
Sybariengine.dll9.1.1097.6136.19207-Gen-200817: 20x 86
Custom.dllNon applicabile73,11207-Gen-200817: 20x 86
Antigen 9.0 per Exchange
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Getenginefiles.exe9.0.1055.76527,87207-Gen-200816: 56x 86
Sfxcab.exe9.0.1055.7643.00807-Gen-200816: 49x 86
Custom.dllNon applicabile73,11207-Gen-200816: 49x 86
Antigen 9.0 per SMTP Gateways con SP1
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Aexmladapter.dll9.1.1097.6515,58407-Gen-200819: 09x 86
Antigenasj.dll9.1.1097.6310,78407-Gen-200819: 09x 86
Antigenclient.exe9.1.1097.61,147,39207-Gen-200819: 09x 86
Antigeninternet.exe9.1.1097.6744,96007-Gen-200819: 09x 86
Antigenrealtime.exe9.1.1097.6724,99207-Gen-200819: 09x 86
Antigenservice.exe9.1.1097.61,385,98407-Gen-200819: 09x 86
Antigensmtpsink.dll9.1.1097.6418,81607-Gen-200819: 09x 86
Getenginefiles.exe9.1.1097.6538,62407-Gen-200819: 09x 86
Sfxcab.exe9.1.1097.642.49607-Gen-200819: 09x 86
Sybariengine.dll9.1.1097.6136.19207-Gen-200819: 09x 86
Custom.dllNon applicabile73,11207-Gen-200819: 09x 86
Antigen 9.0 per SMTP Gateways
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Getenginefiles.exe9.0.1055.76527,87207-Gen-200818: 42x 86
Sfxcab.exe9.0.1055.7642.49607-Gen-200817: 00x 86
Custom.dllNon applicabile73,11207-Gen-200817: 00x 86

Informazioni sull'installazione di hotfix

Per installare questo aggiornamento rapido (hotfix), attenersi alla seguente procedura:
  1. Contattare Microsoft Customer Support Services (CSS) per ottenere l'hotfix appropriato per la versione di Antigen 9.0 e in esecuzione.
  2. Avviare Task Manager e quindi scegliere la scheda processi verificare che il processo di GetEngineFiles.exe non è in esecuzione.

    Nota Se si installa l'aggiornamento rapido mentre il processo di GetEngineFiles.exe è in esecuzione, Antigen 9.0 consente di riavviare il computer una volta applicato l'hotfix.
  3. Chiudere la console di Antigen se è aperto e quindi installare l'aggiornamento rapido (hotfix).

    Nota Quando si installa l'aggiornamento rapido, il programma di installazione dell'aggiornamento rapido termina automaticamente e quindi riavvia i servizi seguenti:
    • I servizi correlati a Exchange
    • Il servizio SMTP (Simple Mail Transfer Protocol
    • Tale servizio
  4. Avviare la console di Antigen e quindi aggiornare il motore di analisi Kaspersky. Per effettuare questa operazione, fare clic su Aggiorna .

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 947184 - Ultima modifica: lunedì 7 luglio 2008 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Antigen 9.0 for Exchange
  • Microsoft Antigen for SMTP Gateways
Chiavi: 
kbmt kbautohotfix kbhotfixserver kbqfe kbfix kbbug kbpubtypekc KB947184 KbMtit
Traduzione automatica articoli
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Clicca qui per visualizzare la versione originale in inglese dell?articolo: 947184
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