Microsoft Dynamics CRM 4.0 Deployment Managerin (Käyttöönoton hallinnan) käyttöoikeustunnuksen päivittäminen aiheuttaa seuraavankaltaisen virhesanoman:

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 947272 - Näytä tuotteet, joita tämä artikkeli koskee.
Laajenna kaikki | Kutista kaikki

Tällä sivulla

Oire

Kun käyttöoikeustunnus yritetään päivittää Microsoft Dynamics CRM 4.0 Deployment Managerissa, seuraavankaltainen virhesanoma tulee näkyviin:
Määritetty käyttöoikeuskoodi ei kelpaa päivitettäväksi. Varmista, että käyttöoikeuskoodi on määritetty oikein, ja yritä uudelleen.
Tämä virhesanoma tulee näkyviin, kun jokin seuraavista ehdoista täyttyy:
  • Ilmenemistapa 1: Microsoft Dynamics CRM 4.0 on asennettu Enterprise-kokeilukäyttöoikeutta käyttäen, ja käyttöoikeus yritetään päivittää Microsoft Dynamics CRM 4.0 Workgroup ?käyttöoikeudeksi tai Microsoft Dynamics CRM 4.0 Professional ?käyttöoikeudeksi.
  • Ilmenemistapa 2: Microsoft Dynamics CRM 4.0 on asennettu Professional-kokeilukäyttöoikeutta käyttäen, ja käyttöoikeus yritetään päivittää Microsoft Dynamics CRM 4.0 Workgroup ?käyttöoikeudeksi.
  • Ilmenemistapa 3: Microsoft Dynamics CRM 4.0 on asennettu 30 päivän kokeilukäyttöoikeutta käyttäen, ja käyttöoikeus yritetään päivittää Microsoft Developer Network (MSDN) -käyttöoikeudeksi.
  • Ilmenemistapa 4: Microsoft Dynamics CRM 4.0 on asennettu 30 päivän kokeilukäyttöoikeutta käyttäen, ja käyttöoikeus yritetään päivittää Business Ready License (BRL) -käyttöoikeudeksi.

Syy

Syy 1

Microsoft Dynamics CRM Enterprise -kokeilukäyttöoikeutta ei voi päivittää Microsoft Dynamics CRM Professional -käyttöoikeudeksi tai Microsoft Dynamics CRM Workgroup ?käyttöoikeudeksi.

Syy 2

Microsoft Dynamics CRM Professional -käyttöoikeutta ei voi päivittää Microsoft Dynamics CRM Workgroup -käyttöoikeudeksi.

Syy 3

30 päivän Microsoft Dynamics CRM -kokeilukäyttöoikeutta ei voi päivittää MSDN-käyttöoikeudeksi.

Syy 4

30 päivän Microsoft Dynamics CRM -käyttöoikeutta ei voi päivittää BRL-käyttöoikeudeksi.

Workaround

Voit kiertää ongelman asentamalla uuden Microsoft CRM 4.0 -käyttöönoton uutta käyttöoikeustunnusta käyttäen, luomalla uuden organisaation ja tuomalla organisaation aiemmasta asennuksesta. Noudata seuraavia ohjeita. Kun olet noudattanut ohjeita, voit kirjautua uuteen organisaatioon. Kaikki aiemman asennuksen tiedot ja mukautukset ovat näkyvissä uudessa organisaatiossa.

Huomautus Noudattamalla näitä ohjeita voit myös vaihtaa käyttöoikeuden vanhempaan versioon Microsoft Dynamics CRM 4.0:n asennuksen jälkeen.
  1. Hanki käyttöoikeustunnus, jota haluat käyttää. Lisätietoja käyttöoikeustunnuksista on seuraavassa Microsoftin verkkosivustossa:
    http://www.microsoft.com/dynamics/purchase/editionsandlicensing.mspx
  2. Varmuuskopioi Organisaation_nimi_MSCRM-tietokanta.
  3. Poista Microsoft Dynamics CRM 4.0:n asennus. Noudata seuraavia ohjeita:
    1. Napsauta Käynnistä-painiketta, valitse Ohjauspaneeli ja valitse Lisää tai poista sovellus.
    2. Etsi Microsoft Dynamics CRM Server -ohjelma ja valitse Muuta tai poista.
    3. Valitse Poista.
  4. Kun Microsoft Dynamics CRM 4.0:n asennus on poistettu, poista MSCRM_Config-tietokanta palvelimesta, jossa Microsoft SQL Server on käytössä.
  5. Käynnistä uudelleen palvelin, jossa SQL Server on käytössä.
  6. Asenna Microsoft Dynamics CRM 4.0 hankkimaasi uutta käyttöoikeustunnusta käyttäen.

    Huomautus Kun ohjelma pyytää organisaation nimen, käytä jotakin muuta kuin organisaation alkuperäistä nimeä. Vanha organisaatio tuodaan uuteen asennukseen. Sen vuoksi asennuksessa ei ole tarkoituksenmukaista luoda organisaatiota, jolla on sama nimi kuin vanhalla organisaatiolla.
  7. Asenna Hotfix-korjaus 950680. Lisätietoja tästä Hotfix-korjauksesta saat napsauttamalla seuraavaa Microsoft Knowledge Base -artikkelinumeroa:
    950680 Työnkulun sääntöjä ei enää voi suorittaa, kun organisaatio tuodaan Microsoft Dynamics CRM 4.0:ssa Deployment Managerin (Käyttöönoton hallinnan) ohjatulla organisaation tuomistoiminnolla
  8. Kun asennustoimet on tehty, suorita Deployment Manager -toimet.
  9. Napsauta Organization-kohtaa hiiren kakkospainikkeella ja valitse Import Organization.
  10. Poista kohdassa 6 luomasi organisaatio valitsemalla OK.
  11. Noudata ohjatun organisaation tuomisen ohjeita ja napsauta sitten Organisaation_nimi_MSCRM-tietokantaa, jonka varmuuskopioit kohdassa 2.
  12. Kirjaudu sisään organisaatioon.
Huomautuksia
  • Myös Microsoft Dynamics CRM-Exchange-sähköpostireititin ja Microsoft SQL Server 2005 Reporting Services Data Connector täytyy asentaa uudelleen, jotta nämä komponentit voidaan rekisteröidä uuteen MSCRM_Config-tietokantaan.
  • Microsoft Dynamics CRM for Microsoft Office Outlook -asiakasohjelma tai tietojen siirron hallinta täytyy ehkä asentaa uudelleen, jos Organisaation_nimi_MSCRM-tietokannan nimi on muutettu.

Ominaisuudet

Artikkelin tunnus: 947272 - Viimeisin tarkistus: 2. kesäkuuta 2008 - Versio: 2.0
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Dynamics CRM 4.0
Hakusanat: 
kberrmsg kbexpertisebeginner kbtshoot kbprb kbpubtypekc kbmbsadministration kbmbsmigrate kbhowto kbexpertiseinter KB947272

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com