當您嘗試在 Microsoft Dynamics CRM 4.0 Deployment Manager 中升級授權識別碼時出現錯誤訊息:「所輸入的授權碼無法升級」

文章翻譯 文章翻譯
文章編號: 947272 - 檢視此文章適用的產品。
「Microsoft 知識庫」公開網站提供的 Microsoft Dynamics 內容有限。如需 Microsoft Dynamics 的完整內容與其他資源,請造訪:

Dynamics 客戶
Microsoft Dynamics 客戶來源*
Dynamics 夥伴
Microsoft Dynamics 夥伴來源

* 客戶必須有 Microsoft Dynamics 服務計劃,如 Business Ready Enhancement Plan 或「軟體保證」
全部展開 | 全部摺疊

在此頁中

徵狀

當您嘗試在 Microsoft Dynamics CRM 4.0 Deployment Manager 升級授權識別碼時,收到下列錯誤訊息:
所輸入的授權碼無法升級。請確定您已輸入正確的授權碼,然後再試一次。
當下列其中一種狀況成立時,您會收到這個錯誤訊息:
  • 徵狀 1:您使用 Enterprise 試用版授權安裝 Microsoft Dynamics CRM 4.0,並嘗試升級至 Microsoft Dynamics CRM 4.0 Workgroup 授權或 Microsoft Dynamics CRM 4.0 Professional 授權。
  • 徵狀 2:您使用 Professional 試用版授權安裝 Microsoft Dynamics CRM 4.0,並嘗試升級至 Microsoft Dynamics CRM 4.0 Workgroup 授權。
  • 徵狀 3:您使用 30 天試用版授權安裝 Microsoft Dynamics CRM 4.0,並嘗試升級至 Microsoft Developer Network (MSDN) 授權。
  • 徵狀 4:您使用 30 天試用版授權安裝 Microsoft Dynamics CRM 4.0,並嘗試升級至 Business Ready License (BRL)。

發生的原因

原因 1

您無法將 Microsoft Dynamics CRM Enterprise 試用版授權升級至 Microsoft Dynamics CRM Professional 授權或 Microsoft Dynamics CRM Workgroup 授權。

原因 2

您無法將 Microsoft Dynamics CRM Professional 授權升級至 Microsoft Dynamics CRM Workgroup 授權。

原因 3

您無法將 Microsoft Dynamics CRM 30 天試用版授權升級至 MSDN 授權。

原因 4

您無法將 Microsoft Dynamics CRM 30 天試用版授權升級至 BRL。

其他可行方案

若要解決這個問題,請使用新的授權識別碼安裝新的 Microsoft CRM 4.0 部署並建立新的組織,然後從現有安裝匯入組織。若要執行這項操作,請依照下列步驟執行。執行這些步驟之後,您就能登入新的組織,並檢閱現有安裝的所有資料與自訂內容。

注意 您也可以在安裝 Microsoft Dynamics CRM 4.0 之後,執行這些步驟為授權試別碼降級。
  1. 取得您要使用的授權識別碼。如需有關授權識別碼的詳細資訊,請造訪下列 Microsoft 網站:
    http://www.microsoft.com/dynamics/purchase/editionsandlicensing.mspx
  2. 備份組織名稱_MSCRM 資料庫。
  3. 解除安裝 Microsoft Dynamics CRM 4.0。如果要執行這項操作,請依照下列步驟執行:
    1. 按一下 [開始],按一下 [控制台],然後按一下 [新增或移除程式]
    2. 找到 Microsoft Dynamics CRM Server 程式,然後按一下 [變更/移除]
    3. 按一下 [解除安裝]
  4. 為 Microsoft Dynamics CRM 4.0 解除安裝之後,請刪除正在執行 Microsoft SQL Server 之伺服器上的 MSCRM_Config 資料庫。
  5. 重新啟動正在執行 SQL Server 的伺服器。
  6. 使用您所取得的新的授權識別碼安裝 Microsoft Dynamics CRM 4.0。

    注意 當畫面出現提示,請您輸入組織名稱時,請使用和原始組織名稱不同的新名稱。您會將舊組織匯入新的安裝。因此,您不要讓安裝建立具有相同名稱的組織。
  7. 安裝 Hotfix 950680。 如需有關此 Hotfix 的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
    950680 當您在 Microsoft Dynamics CRM 4.0 中使用 Deployment Manager Import Organization Wizard 來匯入組織時,工作流程規則將不再執行
  8. 請在安裝完成後,執行 Deployment Manager 程序。
  9. 用滑鼠右鍵按一下 [組織],然後按一下 [匯入組織]
  10. 按一下 [確定] 以刪除您在步驟 6 所建立的組織。
  11. 請完成「匯入組織精靈」的步驟,然後按一下您在步驟 2 備份的組織名稱_MSCRM 資料庫。
  12. 登入組織。
注意
  • 如果您計劃在新環境中使用相同的 Microsoft Dynamics CRM E-mail Router,必須執行 Microsoft Dynamics CRM E-mail Router 適用的「設定精靈」進行相關設定。
  • 您必須安裝 Microsoft Dynamics CRM Data Connector for SQL Server Reporting Services,對新的 MSCRM_Config 資料庫註冊元件。
  • 您必須執行 Microsoft Dynamics CRM Client for Outlook 的「設定精靈」,以連線至新的 Microsoft Dynamics CRM 伺服器。
  • 您必須重新安裝 Data Migration Manager 才能指向新的 Microsoft Dynamics CRM 伺服器。

屬性

文章編號: 947272 - 上次校閱: 2010年9月30日 - 版次: 5.0
這篇文章中的資訊適用於:
  • Microsoft Dynamics CRM 4.0
關鍵字:?
kberrmsg kbexpertisebeginner kbtshoot kbprb kbmbsadministration kbmbsmigrate kbhowto kbexpertiseinter KB947272
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com