FIX: A file that is deleted from the source branch still exists in the target branch after you perform a merge operation in Visual Studio 2008 Team Foundation Server

Article translations Article translations
Article ID: 947455 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

After you perform a merge operation in Microsoft Visual Studio 2008 Team Foundation Server, a file that is deleted from the source branch still exists in the target branch.

Note This problem occurs only in special scenarios. For example, consider the following scenario:
  • In Visual Studio 2008 Team Foundation Server source control, you create a new folder, and then you name the new folder Trunk.
  • In the Trunk folder, you create a new file, you name the new file File.txt, and then you insert a single line of text into the file.
  • You check in the changes.
  • You branch the Trunk folder as a new branch folder, you name the new branch folder Edit-branch, and then you check in the changes.
  • You branch the Trunk folder as a new branch folder, you name the new branch folder Delete-branch, and then you check in the changes.
  • In the Delete-branch folder, you delete the File.txt file.
  • In the Edit-branch folder, you add another single line of text to the contents of the file.
  • You merge the Edit-branch folder to the Trunk folder, and then you check in the changes.
  • You merge the Trunk folder to the Delete-branch folder, and then you check in the changes.

    Note If a conflict occurs, resolve the conflicts. To do this, click the option to discard the changes from the source branch.
  • You check in the changes.
  • You merge the Delete-branch folder to the Trunk folder.
  • You check the File.txt file in the Trunk folder.
In this scenario, the File.txt file still exists in the Trunk folder. However, the expected behavior is that the File.txt file is deleted.

CAUSE

This problem occurs because an SQL stored procedure is called during the merge operation.

RESOLUTION

Hotfix information



A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft Web site:
http://code.msdn.microsoft.com/KB947455

Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support


Note You must apply this hotfix to the Team Foundation Server application tier server.

Prerequisites

You must have Visual Studio 2008 Team Foundation Server installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.teamfoundation.databaseinstaller.dll9.0.21022.77426393629-Apr-200816:49x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 947455 - Last Review: May 30, 2008 - Revision: 1.3
APPLIES TO
  • Microsoft Visual Studio Team System 2008 Team Foundation Server
Keywords: 
kbfix kbexpertiseadvanced kbqfe KB947455

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com