Error message when you select a data source in a protection group in System Center Data Protection Manager 2007: "This item cannot be protected because some prerequisite software is missing. (ID: 31008)"

Article translations Article translations
Article ID: 947470 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You select the Create protection group option or the Modify protection group option in Microsoft System Center Data Protection Manager 2007. Then, you select a data source to protect in the protection group.

When you do this, you may receive the following error message:
This item cannot be protected because some prerequisite software is missing. Ensure that all prerequisite software is installed and then protect this item. (ID: 31008)

CAUSE

This issue may occur for one of the following reasons:
  • The protected computer does not have one or more prerequisite software updates installed.
  • The protected computer has the prerequisite software updates installed. However, the protection agent has not yet been updated.

    Note By default, the protection agent is updated every 30 minutes.
Note A protected computer is a computer that contains data sources that are backed up by System Center Data Protection Manager.

RESOLUTION

To resolve this issue, follow these steps.

Step 1: Verify that the protected computer has the appropriate updates installed

Verify that the protected computer meets the protected computer software requirements. To view these requirements, visit the following Web site:
http://technet.microsoft.com/en-us/library/bb808827.aspx
Note Software update 940349 must be installed on the Data Protection Manager server and on each protected computer that is running Windows Server 2003 Service Pack 1 (SP1) or a later version of Windows Server 2003.

For more information about software update 940349, click the following article number to view the article in the Microsoft Knowledge Base:
940349 Availability of a Volume Shadow Copy Service (VSS) update rollup package for Windows Server 2003 to resolve some VSS snapshot issues
Notes
  • If the data source is located on a server cluster, each cluster node must be updated.
  • If the data source is located on a Microsoft Office SharePoint Portal Server farm, each member server of the farm must be updated.
  • This requirement also includes any instances of SQL Server that may be used as a back end for the farm.

Step 2: Update the protection agent

After the prerequisite software updates have been installed, update the protection agent. To do this, follow these steps:
  1. Start the Data Protection Manager 2007 Administrator Console, and then click the Management tab.
  2. Click the Agents tab, and then click Refresh information in the Action pane.
  3. Verify that OK appears in the Agent Status column for each protected server.
  4. Click the Protection tab, and then follow these steps:
    1. Create a new protection group, or modify an existing protection group.
    2. Select a data source.
    Verify that you can add a data source to the protection group successfully.

MORE INFORMATION

For more support information about System Center Data Protection Manager 2007, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/dpm/bb737892.aspx

Properties

Article ID: 947470 - Last Review: January 6, 2009 - Revision: 2.0
APPLIES TO
  • Microsoft System Center Data Protection Manager 2007
Keywords: 
kberrmsg kbtshoot kbprb KB947470

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com