O spooler de impressora pode falhar aleatoriamente em um computador Windows Server que tem uma impressora HP instalada

Este artigo fornece uma solução para um problema em que o spooler da impressora falha aleatoriamente em um computador Windows Server que tem uma impressora HP instalada.

Aplica-se a: Windows Server 2012 R2
Número de KB original: 947477

Sintomas

Em um computador baseado no Windows Server que tem uma impressora HP instalada, o spooler da impressora pode falhar aleatoriamente.

Motivo

Esse problema ocorre devido a um dos seguintes arquivos:

  • Hpbmmon.dll (Hp Master Monitor)
  • Hpzpi4wm.dll (processador de impressão HP)
  • Hpzpp4wm.dll (processador de impressão HP)
  • HPtcpMon.dll (monitor de porta do HP TCP)

Resolução

Para resolve esse problema, entre em contato com o fabricante de terceiros para obter ajuda.

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para saber mais sobre como fazer o backup e restaurar o registro, consulte Como fazer o backup e restaurar o registro no Windows.

Solução alternativa para o problema causado pelo Hpbmmon.dll

Para resolver esse problema, remova o Hp Master Monitor. Para fazer isso, siga estas etapas:

  1. Inicie o Editor do Registro.

  2. Localize e clique na subchave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Master Monitordo registro .

  3. No menu Arquivo , clique em Exportar.

  4. Na caixa Nome do arquivo , digite HPprinter e clique em Salvar.

    Observação

    Se você quiser restaurar essa subchave de registro, clique duas vezes no arquivo HPprinter.reg que você salvar nesta etapa.

  5. Clique com o botão direito do mouse na entrada do registro do HP Master Monitor e clique em Excluir.

  6. Clique em Sim.

  7. Saia do Editor do Registro e reinicie o computador.

  8. Renomeie o arquivo Hpbmmon.dll para Hpbmmon.old. O arquivo está no arquivo de C:\WINDOWS\system32\Hpbmmon.dll de localização.

Solução alternativa para o problema causado por Hpzpi4wm.dll ou Hpzpp4wm.dll

Observação

Se essa impressora não funcionar com o WinPrint, as etapas a seguir poderão não funcionar. Se essa situação ocorrer, entre em contato com a HP para atualizar o processador de impressão HPZPP4WM para a versão mais recente.

  1. Clique em Iniciar e depois em Painel de Controle.
  2. Clique duas vezes em Impressoras e Faxes.
  3. Clique com o botão direito do mouse na impressora que você deseja usar e clique em Propriedades.
  4. Clique na guia Avançado e clique em Processador de Impressão.
  5. Clique em WinPrint na caixa Processador de impressão , clique em RAW na caixa Tipo de dados Padrão e clique em OK duas vezes.
  6. Renomeie o arquivo Hpzpi4wm.dll para Hpzpi4wm.old. O arquivo está no local: C:\WINDOWS\system32\spool\drivers\w32x86\3\Hpzpi4wm.dll.
  7. Renomeie o arquivo Hpzpp4wm.dll para Hpzpp4wm.old. O arquivo está no local: C:\WINDOWS\system32\spool\PRTPROCS\W32X86\Hpzpp4wm.dll.

Solução alternativa para o problema causado pelo HPtcpMon.dll

  1. Inicie o Editor do Registro.

  2. Localize e clique na subchave do Registro: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Standard TCP/IP Port.

  3. No menu Arquivo , clique em Exportar.

  4. Na caixa Nome do arquivo , digite HPprinter e clique em Salvar.

    Observação

    Se você quiser restaurar essa subchave de registro, clique duas vezes no arquivo HPprinter.reg que você salvar nesta etapa.

  5. Clique com o botão direito do mouse na entrada do Registro de Porta do HP Standard TCP/IP e clique em Excluir.

  6. Clique em Sim.

  7. Localize e clique na subchave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Portdo registro .

  8. Clique duas vezes em Driver e verifique se o valor da caixa de dados Value está tcpmon.dll.

    Observação

    Se a entrada do Registro de Driver não existir ou seu valor não estiver tcpmon.dll, crie a entrada do Registro de Driver e defina seu valor como tcpmon.dll. Para fazer isso, siga estas etapas:

    1. No menu Editar , aponte para Novo e clique em Valor de Cadeia de Caracteres.
    2. Digite Driver e pressione ENTER.
    3. Clique com o botão direito do mouse em Driver e clique em Modificar.
    4. Na caixa de dados Valor , digite tcpmon.dll e clique em OK.
  9. Saia do Editor do Registro e reinicie o computador.

  10. Renomeie o arquivo HPtcpMon.dll para HPtcpMon.old. O arquivo está no local: C:\WINDOWS\system32\HPTcpMon.dll.

Mais informações

Os produtos de terceiros mencionados neste artigo são produzidos por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, implícita ou não, do desempenho ou da confiabilidade desses produtos.