Help and Support

Article ID: 947682 - Last Review: January 28, 2008 - Revision: 1.0

The DPM protection agent service cannot start in System Center Data Protection Manager 2007

Expand all | Collapse all

SYMPTOMS

After you deploy the DPM protection agent in Microsoft System Center Data Protection Manager 2007, the DPM protection agent service cannot start on the protected servers. (A protected server is a server that contains data sources that are protection group members.)

Additionally, the following event is logged in the System log on the protected servers:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7024
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
The DPMRA service terminated with service-specific error 10048 (0x2740).

CAUSE

This problem may occur for one of the following reasons:
  • Another process is using TCP port 5718 and TCP port 5719. These two ports are required by the DPM protection agent service.
  • TCP port 5718 and TCP port 5719 are not open for firewall applications or for firewall devices on the computer.

RESOLUTION

To resolve this problem, find the process that is using the required TCP ports. To do this, follow these steps:
  1. Open a command prompt, and then run the following commands at the command prompt:
    netstat -ano > netstat.txt
    tasklist > tasklist.txt
    tasklist /svc >svclist.txt
    Note In this step, the command outputs of the netstat command and the tasklist command are written to text files so that you can check the outputs more easily. Run the tasklist command together with the /svc switch because the process that is using the required ports may be running as a service.
  2. Open the text files that were generated in step 1. To do this, run the following commands at the command prompt:
    notepad netstat.txt
    notepad tasklist.txt
    notepad svclist.txt
  3. In the Netstat.txt file, find any entries that correspond to TCP port 5718 and to TCP port 5719. Note the process identifier (PID) for each entry.
  4. In the Tasklist.txt file, locate the PIDs that you found in step 3 to determine which processes are using the required ports. If you do not find the PIDs in the Tasklist.txt file, try to find the PIDs in the Svclist.txt file.
  5. After you find out which process is using the required ports, configure the corresponding program to use other available ports. If you cannot change the program's ports or if the program uses ports dynamically, you must stop the program.
If this problem is not resolved after you follow these steps, determine whether the firewall applications require that you verify these ports, and then manually open the ports.

MORE INFORMATION

Data Protection Manager 2007 and protected servers open connections over TCP port 5718 and over TCP port 5719 to enable Data Protection Manager operations, such as synchronization and recovery. The current problem may occur on protected servers that are running the Microsoft Exchange System Attendant service. This service uses TCP ports dynamically. This service may take one or both of the required ports.

Data Protection Manager 2007 also uses the following ports:
  • TCP 135 dynamic
  • User Datagram Protocol (UDP) 53
  • UDP 88
  • TCP 88
  • UDP 137
  • UDP 138
  • TCP 139
  • TCP 389
  • UDP 389

APPLIES TO
  • Microsoft System Center Data Protection Manager 2007
Keywords: 
kbexpertiseinter kbtshoot kbprb KB947682

Article Translations