DPM 보호 에이전트 서비스를 시작할 수 없습니다.

이 문서에서는 DPM(데이터 보호 관리자) 보호 에이전트 서비스를 시작할 때 서비스별 오류 10048(0x2740) 오류로 종료된 DPMRA 서비스를 수신하는 문제를 해결하는 데 도움이 됩니다.

원래 제품 버전: System Center Data Protection Manager
원래 KB 번호: 947682

증상

Microsoft System Center Data Protection Manager에서 DPM 보호 에이전트를 배포한 후에는 보호된 서버에서 DPM 보호 에이전트 서비스를 시작할 수 없습니다. 보호된 서버는 보호 그룹 구성원인 데이터 원본을 포함하는 서버입니다.

원인

이 문제는 다음 이유 중 하나로 인해 발생할 수 있습니다.

  • 또 다른 프로세스는 TCP 포트 5718 및 TCP 포트 5719를 사용하는 것입니다. 이러한 두 포트는 DPM 보호 에이전트 서비스에 필요합니다.
  • TCP 포트 5718 및 TCP 포트 5719는 방화벽 애플리케이션 또는 컴퓨터의 방화벽 디바이스에 대해 열려 있지 않습니다.

해결 방법 1

이 문제를 resolve 필요한 TCP 포트를 사용하는 프로세스를 찾습니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 명령 프롬프트 창을 엽니다. 명령 프롬프트에서 다음 명령을 실행합니다.

    netstat -ano > netstat.txt
    tasklist > tasklist.txt
    tasklist /svc >svclist.txt
    

    참고

    이 단계에서는 명령 및 tasklist 명령의 netstat 명령 출력이 텍스트 파일에 기록되므로 출력을 더 쉽게 검사 수 있습니다. 필요한 포트를 tasklist 사용하는 프로세스가 서비스로 실행될 수 있으므로 스위치와 /svc 함께 명령을 실행합니다.

  2. 1단계에서 생성된 텍스트 파일을 엽니다. 이렇게 하려면 명령 프롬프트에서 다음 명령을 실행합니다.

    notepad netstat.txt
    notepad tasklist.txt
    notepad svclist.txt
    
  3. Netstat.txt 파일에서 TCP 포트 5718 및 TCP 포트 5719에 해당하는 항목을 찾습니다. 각 항목에 대한 PID(프로세스 식별자)를 확인합니다.

  4. Tasklist.txt 파일에서 3단계에서 찾은 PID를 찾아 필요한 포트를 사용하는 프로세스를 확인합니다. Tasklist.txt 파일에서 PID를 찾을 수 없는 경우 Svclist.txt 파일에서 PID를 찾아보세요.

  5. 필요한 포트를 사용하는 프로세스를 찾은 후 사용 가능한 다른 포트를 사용하도록 해당 프로그램을 구성합니다. 프로그램의 포트를 변경할 수 없거나 프로그램에서 동적으로 포트를 사용하는 경우 프로그램을 중지해야 합니다.

참고

다른 애플리케이션이 포트 또는 포트(5718 및 5719)를 사용하는 경우 포트를 변경할 수 없습니다. 이 경우 대신 SetAgentcfg.exe 도구를 사용할 수 있습니다. 이 도구는 DPM 에이전트가 사용하는 기본 포트를 변경하는 기능을 제공합니다.

DPM 에이전트에서 사용하는 포트를 변경하려면 문제가 발생하는 보호된 컴퓨터에서 다음 단계를 수행합니다. 다시 할당한 포트가 다른 애플리케이션에서 사용되지 않는지 확인합니다.

참고

DPM 설치 경로를 나열하려면 다음 명령을 실행합니다.

Reg query "HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Setup" /v installpath

  1. DPM 서버에서 SetAgentcfg.exe 파일을 찾습니다. 기본적으로 파일은 에 있습니다 %PROGRAMFILES%\Microsoft DPM\DPM\Setup\SetAgentCfg.exe.

  2. 문제가 발생한 보호된 컴퓨터에 파일을 복사합니다. 에이전트 DPM\Bin 디렉터리에 파일을 복사합니다. 기본적으로 파일은 에 있습니다 %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  3. 문제가 발생한 보호된 컴퓨터에서 관리 명령 프롬프트 창을 엽니다.

  4. 명령 프롬프트 창에서 SetAgentCfg.exe 파일이 복사된 디렉터리로 변경합니다. 예를 들어 디렉터리 로 변경합니다 %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  5. 다음 명령을 실행하여 DPM 에이전트에서 사용하는 포트를 변경합니다.

    SetAgentCfg e dpmra <port number> <alternate port number>
    
  6. DPMRA 서비스를 다시 시작합니다.

이러한 단계에서 이 문제를 resolve 않는 경우 방화벽 애플리케이션에서 이러한 포트를 확인해야 하는지 여부를 결정합니다. 그런 다음 포트를 수동으로 엽니다.

해결 방법 2

TCP 포트 5718 및 5719를 예약하려면 Windows Server 2003 또는 Windows 2000 Server를 실행하는 컴퓨터에서 다양한 임시 포트를 예약하는 방법에 설명된 단계를 따릅니다.

추가 정보

데이터 보호 관리자 및 보호된 서버는 TCP 포트 5718 및 TCP 포트 5719를 통해 연결을 열어 동기화 및 복구와 같은 Data Protection Manager 작업을 사용하도록 설정합니다. 현재 문제는 Microsoft Exchange 시스템 전화 교환 서비스를 실행하는 보호된 서버에서 발생할 수 있습니다. 이 서비스는 동적으로 TCP 포트를 사용합니다. 이 서비스는 필요한 포트 중 하나 또는 둘 다를 취할 수 있습니다.

또한 Data Protection Manager는 다음 포트를 사용합니다.

  • TCP 135 동적
  • UDP(사용자 데이터그램 프로토콜) 53
  • UDP 88
  • TCP 88
  • UDP 137
  • UDP 138
  • TCP 139
  • TCP 389
  • UDP 389