Auf einem Windows Server 2003-Computer, der einen TCP-Chimney-Abladung Netzwerkadapter verfügt, kann der TCP-Datenstrom beschädigt Wenn der Netzwerkadapter eine MDL-Kette gibt an, deren Start-MDL einen Offset ungleich 0 (null) hat

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Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Für einen Netzwerkadapter auf einem Windows Server 2003-Computer ist ein NDIS (Network Device Interface Specification)-Treiber installiert.
  • Der NDIS-Treiber unterstützt TCP-Chimney-Abladung.
  • Eine Anwendung ruft die CreateFile-Funktion, die ReadFile-Funktion oder die Funktion "WriteFile" Zugriff auf Dateien auf einem Netzlaufwerk über den Netzwerkadapter.
  • Der Netzwerkadapter gibt eine Kette von Speicher Deskriptor Liste (MDL) und der Offset auf die erste MDL ist ungleich 0 (null).
In diesem Szenario der TCP-Datenstrom ist möglicherweise beschädigt, und eine Lesezugriffsverletzung auftreten. Daher kann die Anwendung nicht mehr reagiert oder unerwartet beendet.

Ursache

Wenn der TCP/IP-Treiber der Übertragungsverschiebung Netzwerkadapter Hinweis auf ein Hinweis darauf TDI (Transport Data Interface) von Receive zugeordnet ist, berechnet der TCP/IP-Treiber fälschlicherweise die Pufferlänge empfangen. Daher versucht der TDI-Client Zugriff auf Daten hinter dem Ende des Puffers.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix wird möglicherweise zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemlösungen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen, die für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, liegt dies daran, dass ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix anwenden zu können, müssen Sie Windows Server 2003 Service Pack 1 oder Windows Server 2003 Service Pack 2 auf dem Computer installiert haben.

Weitere Informationen finden Sie die folgende KB-Artikelnummer:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time (UTC) aufgelistet. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC-Zeit und lokaler Zeit zu ermitteln, verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung.
Windows Server 2003 mit Service Pack 1, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
TCPIP.sys5.2.3790.3098393,728 05-Mär-200806: 18X 86
Windows Server 2003 mit Service Pack 2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
TCPIP.sys5.2.3790.4246390,14404-Mär-200810: 15X 86
Windows Server 2003 mit Service Pack 1, x 64-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
TCPIP.sys5.2.3790.3098826,88004-Mär-200811: 34X 64
Windows Server 2003 mit Service Pack 2, x 64-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
TCPIP.sys5.2.3790.4246781,82404-Mär-200814: 53X 64

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 947775 - Geändert am: Freitag, 11. Dezember 2009 - Version: 3.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
Keywords: 
kbmt kbautohotfix kbwinserv2003postsp2fix kbexpertiseinter kbexpertiseadvanced kbbug kbfix kbhotfixserver kbqfe KB947775 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 947775
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