Help and Support
 

powered byLive Search

Error message when you try to reinstall Microsoft Dynamics CRM 3.0 after you uninstall Microsoft Dynamics CRM 4.0: "Microsoft.Crm.Setup.Server.ConfigureServiceVirtualDirAction failed"

Article ID:947997
Last Review:January 29, 2008
Revision:1.0
On This Page

SYMPTOMS

Consider the following scenario. You upgrade from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0. Then, you use Add or Remove Programs in Control Panel to uninstall Microsoft Dynamics CRM 4.0. Next, you try to use the installation wizard to reinstall Microsoft Dynamics CRM 3.0, and you use the default Web site that is listed in the installation wizard. In this scenario, you receive the following error message:
Microsoft.Crm.Setup.Server.ConfigureServiceVirtualDirAction failed. ---> System.Runtime.InteropServices.COMException (0x800700B7): Cannot create a file when that file already exists.

Back to the top

CAUSE

This problem occurs because some files remain on the Web site after you uninstall Microsoft Dynamics CRM 4.0.

Back to the top

RESOLUTION

To work around this problem, use one of the following methods.

Back to the top

Method 1

Manually remove the Microsoft Dynamics CRM 4.0 Web site. To do this, follow these steps:
1.Log on to the computer that is running Internet Information Services (IIS).
2. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
3. Expand the computer name, and then expand Web Sites.
4. Right-click the Microsoft Dynamics CRM 4.0 Web site, click Stop, and then click Yes.

Note By default, the name of the Microsoft Dynamics CRM 4.0 Web site is Microsoft Dynamics CRM.
5. Right-click the Microsoft Dynamics CRM 4.0 Web site, and then click Properties.
6.Click the Home Directory tab, click DefaultAppPool in the Application pool list, and then click Remove.
7. Click the ISAPI Filters tab, click CRM.Default.Addon isapi, and then click Remove.
8. Click OK.
9. Expand Application Pools, right-click the Microsoft Dynamics CRM 4.0 application pool, click Delete, and then click Yes.

Note By default, the name of the application pool is CRMAppPool.
10. Close IIS Manager.

Back to the top

Method 2

Create a new Web site, and then use the new Web site when you reinstall Microsoft Dynamics CRM 3.0.

Back to the top


APPLIES TO
Microsoft Dynamics CRM 3.0

Back to the top

Keywords: 
kbbug kberrmsg kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter KB947997

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.