Article ID: 948098 - Last Review: January 23, 2008 - Revision: 1.0

SCOM 2007: Gateway server is not working properly after installation.

Expand all | Collapse all
Source: Microsoft Support

RAPID PUBLISHING

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Result

Gateway server is not working properly after installation. The server status is always displayed as “not monitored” in SCOM administrator console -> Administration -> manager servers.

Cause

The gateway server is detected as an “Agent” instead of a server with an incorrect gateway server installation method. If we install the gateway server before we register the gateway server in SCOM database, this issue may occur. Think about the following scenario: 

In SCOM 2007 operation console, navigate to Administration -> Settings -> Security. 

Select the “Review new manual agent installations in pending management server” option. Now, install the gateway server. The health service on the gateway server is trying to communicate with the root management server. As there aren’t any records in SCOM database for the gateway server, the root management server will not recognize this health service as a gateway server but will recognize it as a manually installed Agent. If you also select the Auto-Approve option in Security settings, this gateway server will be approved automatically as an “Agent”.

After that, even after running the “Microsoft.EnterpriseManagemt.GatewayApprovalTool” tool to approve this gateway server, the gateway server will not work properly as it has already been recognized as an “Agent” role.

Resolution



First, register the gateway server before starting to install SCOM gateway server. The detailed steps are:

1.      Uncheck the “Auto-approve new manually installed agents” check box if it is enabled.

2.      Uninstall the failed Gateway server if you face the above issue.

3.      In the MOM Operation Console, delete the existing records of the problematic gateway server under both the Management servers and the Agent Managed (if it exists).

4.      Wait until there is no record returned when you run following SQL query:
Select * from basemanagedentity where fullname like '%<gateway server Name>%'

Note: Step 2 and 3 may require several hours to finish. As a quick workgroup, we can change the server NetBIOS name on the problematic server to a new one. Then go to step 4.

5.      In step 4, try to register the gateway server first before installing it. Please go to the root management server and run the following command line to register a gateway server:

Microsoft.EnterpriseManagemt.GatewayApprovalTool /ManagementServer=<management Server FQDN_name> /PrincipalName=<gateway_server_FQDN_name> /Action=Create

Note: if you changed the server name on the gateway server, please ensure that the new server name is registered in DNS before you run this command.

   Run the following SQL query to ensure that the gateway creation is ok:

         SELECT * FROM mtv_healthservice where isgateway =‟1‟

6.      Now, go to the Gateway server to install SCOM gateway again. After installation is finished, wait in the Operations console for several minutes to see if the Gateway server is healthy now.

7.      Wait for several minutes to see if the gateway server will appear under pending management as a manually installed agent or not. If it appears, please reject it.

DISCLAIMER

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, RELIABILITY OR ACCURACY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THIS WEBSITE (THE “MATERIALS”) FOR ANY PURPOSE. THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

APPLIES TO
  • Microsoft System Center Operations Manager 2007
Keywords: 
kbnomt kbrapidpub KB948098