An Internet Explorer 7 browser window does not open on an alternative desktop on a Windows Vista-based computer

Article translations Article translations
Article ID: 948140 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You create multiple desktops on a Windows Vista-based computer.
  • You start Windows Internet Explorer 7 on the default desktop.
  • You switch to an alternative desktop.
In this scenario, when you try to start Internet Explorer 7 on an alternative desktop, the Internet Explorer 7 browser window does not open. Instead, the Internet Explorer 7 browser window opens on the default desktop.

CAUSE

This issue occurs because protected mode has one separate IEUser.exe broker process. This IEUser.exe broker process makes the following decisions:
  • Which browser windows to open.
  • Which third-party programs are hosted in the browser windows.
  • Whether the browser windows are in protected mode.
Because there is one broker process per user, protected mode allows browser windows to open only on the default desktop.

WORKAROUND

To work around this issue, start Internet Explorer 7 on the default desktop.

Properties

Article ID: 948140 - Last Review: August 19, 2011 - Revision: 2.1
APPLIES TO
  • Windows Internet Explorer 9
  • Windows Internet Explorer 7 in Windows Vista
Keywords: 
kbexpertisebeginner kbtshoot KB948140

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com