Ocorrer problemas no Windows Server 2008 depois de desinstalar um cluster de activação pós-falha do SQL Server 2005 ou depois de instalar uma correcção do Service Pack 2 ou o SQL Server 2005 Service Pack 2 num cluster de activação pós-falha do SQL Server 2005

Traduções de Artigos Traduções de Artigos
Artigo: 948210 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Detectar os seguintes problemas num servidor com o Windows Server 2008.

Problema 1

Desinstala um cluster de activação pós-falha do Microsoft SQL Server 2005. No entanto, o grupo que contém o disco partilhado ainda aparece na gestão de clusters de activação pós-falha. Se instalar um novo cluster de activação pós-falha do SQL Server 2005, o grupo aparece na página Selecção de grupo de cluster. Consulte a solução alternativa 1.

Problema 2

Instale o SQL Server 2005 Service Pack 2 (SP2) ou uma correcção com o SQL Server 2005 SP2 no nó principal de um cluster de activação pós-falha do SQL Server 2005. O programa de configuração do SQL Server 2005 SP2 ou da correcção indica que a instalação teve êxito. No entanto, SQL Server 2005 SP2 ou a correcção baseado em SQL Server 2005 SP2 não está instalada em nós remotos.

Este problema ocorre se a nós remotos não tem espaço suficiente na unidade C. Consulte a solução alternativa 2.

Causa

Causa 2

Problema 2 ocorre porque a ferramenta Msiexec.exe devolve o código de saída 0 se a ferramenta não é possível extrair o pacote para o SQL Server 2005 SP2. O código de saída 0 notifica-o programa de configuração do SQL Server 2005 SP2 ou da correcção com o SQL Server 2005 SP2 se SQL Server 2005 SP2 ou a correcção baseado em SQL Server 2005 SP2 foi instalada com êxito em nós remotos.

Como contornar

Solução 1

Para contornar este problema, elimine manualmente o grupo que contém o disco partilhado na gestão de clusters de activação pós-falha. Para o fazer, siga estes passos:
  1. Clique em Iniciar , aponte para Ferramentas administrativas e, em seguida, clique em Gestão de clusters de activação pós-falha .
  2. Na gestão de clusters de activação pós-falha, expanda o cluster que contém o grupo, expanda Serviços e aplicações , clique com o botão direito do rato no grupo e, em seguida, clique em Eliminar .

Solução 2

Para contornar este problema, certifique-se que a unidade C em nós remotos tem, pelo menos, 400 MB de espaço livre antes de instalar a correcção baseado em SQL Server 2005 SP2 ou o SQL Server 2005 SP2.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Propriedades

Artigo: 948210 - Última revisão: 15 de fevereiro de 2008 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL 2005 Server Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
Palavras-chave: 
kbmt kbexpertiseadvanced kbtshoot kbprb KB948210 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 948210

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com