Help and Support

Article ID: 948252 - Last Review: March 5, 2008 - Revision: 1.2

Error message when you try to install a Windows update, a hotfix, or a service pack after you perform System Restore in Windows Vista: "0x80071A91"

Expand all | Collapse all

SYMPTOMS

After you perform System Restore in Windows Vista, you cannot install a Windows update, a hotfix, or a service pack. Additionally, you may receive the following error message:
80071A91 (ERROR_RM_NOT_ACTIVE)

CAUSE

This problem occurs because, after the System Restore is performed, the Common Log File System (CLFS) transaction logs may be left in an inconsistent state. When the CLFS transaction logs are in an inconsistent state, you may experience the problems that are described in the "Symptoms" section.

RESOLUTION

To resolve this problem, delete the .blf files and the .regtrans-ms files from the %Windir%\System32\SMI\Store\Machine folder. To do this, follow these steps:
  1. Log on as an administrator.
  2. Click Start
    Collapse this imageExpand this image
    the Start button
    , type cmd in the Start Search box, right-click cmd.exe in the Programs list, click Run as administrator, and then click Continue.
  3. At the command prompt, type the following commands. Press ENTER after each command.
    cd /d %SystemRoot%\System32\SMI\Store\Machine
    attrib -s -h *
    del *.blf
    del *.regtrans-ms
  4. Restart the computer.
After you restart the computer, the registry regenerates the deleted files. These regenerated files are in a consistent state.

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
939399  (http://support.microsoft.com/kb/939399/ ) Error message when you try to install updates on a Windows Vista-based computer by using Windows Update or when you try to perform a backup: "Code 0x8007000b"

APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbexpertiseinter kbtshoot kbprb KB948252

Article Translations