ID do artigo: 948252 - Última revisão: terça-feira, 20 de dezembro de 2011 - Revisão: 2.0

Mensagem de erro quando você tenta instalar uma atualização, um hotfix ou um service pack do Windows após executar a Restauração do Sistema no Windows Vista: "0x80071A91"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Após você executar uma Restauração do Sistema no Windows Vista, você não pode instalar uma atualização, um hotfix ou um service pack do Windows. Além disso, a seguinte mensagem de erro pode ser exibida:
80071A91 (ERROR_RM_NOT_ACTIVE)

Causa

Este problema ocorre porque após a Restauração do Sistema ser executada, os logs de transação do Sistema de Arquivos de Log Comuns (CLFS) pode ser deixado em um estado inconsistente. Quando os logs de transação do CLFS estão em um estado inconsistente, você pode enfrentar os problemas descritos na seção "Sintomas".

Resolução

Para resolver esse problema, exclua os arquivos .blf e os arquivos .regtrans-ms da pasta %Windir%\System32\SMI\Store\Machine.

Para podermos corrigir este problema para você, vá para a seção "Corrigir para mim". Se você preferir corrigir o problema sozinho, vá para a seção "Desejo corrigir sozinho".

Corrigir para mim



Para corrigir esse problema automaticamente, clique no botão ou no link Corrigir. Clique em Executar na caixa de diálogo Download do Arquivo e siga as etapas no assistente Corrigir.


Corrigir este problema
Microsoft Fix it 50709


Observações
  • Esse assistente pode estar apenas em inglês. No entanto, a correção automática também funciona em versões do Windows em outros idiomas.
  • Se você não estiver usando o computador que apresenta o problema, salve a solução Fix it em uma unidade flash ou em um CD e execute-a no computador que apresenta o problema.

Vá para a seção "O problema foi corrigido?".



Desejo corrigir sozinho

Para fazer isto, siga as seguintes etapas:
  1. Faça logon como administrador.
  2. Clique no botão Iniciar
    Recolher esta imagemExpandir esta imagem
    , digite cmd na caixa Iniciar Pesquisa, clique com o botão direito do mouse em cmd.exe na lista Programas, clique em Executar como administrador e em Continuar.
  3. No prompt de comando, digite os seguintes comandos. Pressione ENTER após cada comando.
    cd /d %SystemRoot%\System32\SMI\Store\Machine
    attrib -s -h *
    del *.blf
    del *.regtrans-ms
  4. Reinicie o computador.
Após reiniciar o computador, o Registro regenera os arquivos excluídos. Esses arquivos gerados novamente estão em um estado consistente.


O problema foi corrigido?

  • Verifique se o problema foi corrigido. Se o problema tiver sido corrigido, você terá concluído esta seção. Se o problema não tiver sido corrigido, você poderá contatar o suporte (http://support.microsoft.com/contactus/?ln=pt-br#tab0) .
  • Aguardamos seus comentários. Para enviar comentários ou relatar problemas com esta solução, deixe um comentário no blog "Corrigir para mim (http://blogs.technet.com/fixit4me/) " ou envie-nos um email (mailto:fixit4me@microsoft.com?Subject=KB) .

Referências

Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
939399  (http://support.microsoft.com/kb/939399/pt-br/ ) Mensagem de erro ao tentar instalar atualizações em um computador baseado no Windows Vista usando o Windows Update ou quando você tentar realizar um backup: "Código 0x8007000b"

A informação contida neste artigo aplica-se a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
Palavras-chave: 
kbexpertiseinter kbtshoot kbprb KB948252