Mensaje de error cuando intenta iniciar sesión en el cliente Web de Microsoft Dynamics CRM 4.0 o al cliente Microsoft Dynamics CRM para Outlook: "privilegios insuficientes. El usuario ha iniciado la sesión no tiene los permisos de seguridad adecuada"

Seleccione idioma Seleccione idioma
Id. de artículo: 948311 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Síntoma 1

Cuando intenta iniciar sesión en el cliente Web de Microsoft Dynamics CRM 4.0 o el cliente de Microsoft Dynamics CRM para Microsoft Office Outlook, recibirá el siguiente mensaje de error:
Privilegios insuficientes. El usuario ha iniciado la sesión no tiene los permisos de seguridad adecuada ver estos registros o realizar la acción específica. Inténtelo de nuevo esta acción. Si el problema persiste, compruebe a la comunidad de Microsoft Dynamics CRM para soluciones o póngase en contacto con Administrador del sistema Microsoft Dynamics CRM de la organización. Póngase en contacto por último, con soporte técnico de Microsoft.
Si ha habilitado el seguimiento de la plataforma, recibirá un mensaje de error similar al siguiente:
Número de error: 0x80040220
Mensaje de excepción de CRM:: SecLib::CrmCheckPrivilege error. Devolvió hr =-2147220960.
Comprobando privilegios UserId: {CB6CF5E3-C6BD-DC11-AF2F-001AA037AE2D} PrivilegeId: {588725DD-C878-41 C A4C3-5-5EFC93CD3FFD}. Devolvió hr =-2147220960
Nota {588725DD-C878-41 C A4C3-5-5EFC93CD3FFD} es el GUID de privilegio para el nombre de privilegio prvWriteUserSettings.

Síntoma 2

Después de instalar a cliente de Microsoft Dynamics CRM para Microsoft Office Outlook, cuando intenta iniciar Outlook, recibirá el siguiente mensaje de error:
Error al cargar la funcionalidad de Microsoft Dynamics CRM. Pruebe a reiniciar Microsoft Outlook. Póngase en contacto con su administrador de sistema si persiste el error.
Además, se graba el suceso de advertencia siguiente en el registro de aplicación:

Origen: MSCRMAddin o suceso 16930 "inicialización de la interfaz de Microsoft CRM usuario error. Pruebe a reiniciar Microsoft Outlook. HR = 0 X 80131509 "

Origen: MSCRMAddin / ID 16940 "un problema al recuperar información desde el servidor de Microsoft CRM. Compruebe las credenciales de red y conexiones de red e inténtelo de nuevo"

Sin embargo, si tiene la función de administrador del sistema de Microsoft Dynamics CRM, se inicia correctamente, y el cliente de Microsoft Dynamics CRM para cliente de Outlook funciona correctamente. Si a continuación, se quita la función de administrador del sistema y la función original se aplica de nuevo, Outlook se inicia correctamente sin una mensaje de error.

Causa

El problema se produce cuando se cumplen las condiciones siguientes:
  • La función de seguridad actual que está asignada a su registro de usuario no contiene permisos de escritura en la entidad de configuración de usuario.
  • No se especifica un valor para el campo Idioma de Ayuda o para el campo Idioma de la aplicación .
Estos campos están en el registro de configuración de usuario de la base de datos MSCRM organización que está utilizando. Además, no puede actualizar el registro de configuración de usuario al iniciar sesión en Microsoft Dynamics CRM. Por tanto, no se puede iniciar sesión en Microsoft Dynamics CRM.

Solución

Para resolver este problema, siga estos pasos:
  1. Conceder escribir permisos al usuario que está intentando iniciar sesión en Microsoft Dynamics CRM. Para ello, siga estos pasos.

    Nota Debe conceder al usuario un mínimo de permisos de lectura en la configuración de usuario.
    1. Inicie sesión en el cliente Web de Microsoft Dynamics CRM como un usuario que tiene la función de administrador del sistema.
    2. Haga clic en configuración , haga clic en Configuración de división y, a continuación, haga clic en usuarios .
    3. Abra el registro de usuario para el usuario que no puede iniciar sesión en Microsoft Dynamics CRM.
    4. En el panel de exploración, haga clic en funciones .
    5. Haga doble clic en la función que desea modificar.
    6. En la ficha Administración de empresas , haga clic para asignar el privilegio de nivel de usuario al permiso de escritura en Configuración de usuario .
    7. Haga clic en Guardar y cerrar .
  2. Utilice el Kit de desarrollo de software (SDK) de Microsoft Dynamics CRM 4.0 para actualizar registros de configuración de usuario del usuario. Especificar un código de idioma válido para la entidad uilanguageid y para la entidad helplanguageid.

    Nota Para obtener más información acerca de cómo actualizar el registro de configuración de usuario, vea el SDK de Microsoft Dynamics CRM 4.0.

Referencias

Para descargar el SDK de Microsoft Dynamics CRM 4.0, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyId=82E632A7-FAF9-41E0-8EC1-A2662AAE9DFB

Propiedades

Id. de artículo: 948311 - Última revisión: jueves, 12 de febrero de 2009 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Dynamics CRM 4.0
Palabras clave: 
kbmt kbtshoot kbprb kbexpertisebeginner kbmbsmigrate kbexpertiseinter KB948311 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 948311

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com