Mensaje de error cuando intenta comprobar una base de datos en un equipo basado en Windows Server 2003: "Operación finalizó con error-1011 (JET_errOutOfMemory, memoria insuficiente)"

Seleccione idioma Seleccione idioma
Id. de artículo: 948603 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Tenga en cuenta la situación siguiente:
  • Mantenimiento de Active directorio servicio base de datos se está ejecutando en Windows Server 2003.
  • Reiniciar en modo restauración de servicios de directorio para comprobar la base de datos o para borrarlo.
En este escenario, cuando ejecuta una tarea de desfragmentación sin conexión, puede recibir el siguiente resultado:

<target>Archivo de mantenimiento: compacta a <destino> Abrir base de datos [actual]. Ejecutar comando: C:\WINDOWS\system32\esentutl.exe /d "<source> \ntds.dit" /t "<target> \ntds.dit" /p /o defragmentación iniciar modo... <source>Base de datos: <origen> \ntds.dit Temp. <target>Base de datos: <destino> \ntds.dit estado de desfragmentación (% completo) 0 10 20 30 40 50 60 70 80 90 100 |----|----|----|----|----|----|----|----|----|----|....................... Operación terminó con el error-1011 (JET_errOutOfMemory, memoria insuficiente) después de 1431.78 segundos. Generadas 0xfffffc0d(-1011) de código de salida de proceso
El progreso que hace de tarea de desfragmentación antes de que esta salida de error se produzca depende del tamaño de la base de datos y la configuración del servidor. Bases de datos más pequeños no pueden experimentar este problema.

En este escenario, no se ejecuta fuera de la memoria virtual y no hay suficiente memoria física instalada. No importa si se está ejecutando la tarea de desfragmentación junto con el / 3 GB modificador en el archivo Boot.ini.

Nota Este problema no se produce en sistemas de 64 bits.

Causa

Este problema se produce si el equipo basado en Windows Server 2003 tiene más de 3 gigabytes (GB) de memoria física. En este caso, la utilidad Esentutl.exe ofrece caché incorrecta sugerencias de tamaño en el motor de base de datos. Por tanto, el motor de base de datos experimenta un error de asignación de caché y se detiene la desfragmentación sin conexión.

Este problema no se produce en sistemas de 64 bits porque el cálculo de caché de la utilidad Esentutl.exe difiere significativamente en estos sistemas.

Solución

Para resolver este problema, siga estos pasos:
  1. Copie la línea en el archivo Boot.ini que se utiliza para reiniciar Windows Server 2003.
  2. Pegar esta línea en la línea original y después modificarlo para parecerse a lo siguiente:
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" Windows Server 2003, Enterprise DSREPAIR" /FASTDETECT /NOEXECUTE=OPTOUT /3GB /userva=2900 /maxmem=<memory that is available to the operating system> /safeboot:dsrepair
    para cambiar entre modos de inicio, puede Comente la línea correspondiente en el archivo Boot.ini. Esto también significa que no tiene acceso a la consola del servidor para cambiar entre modos de inicio.
  3. Reducir la memoria que está disponible para el sistema operativo de forma que la utilidad Esentutl.exe no proporciona caché incorrecta sugerencias de tamaño. 2048 es un valor que funciona para todas las configuraciones. 2944 es un valor de trabajo para las configuraciones/3 GB. Por ejemplo, una configuración 3 G, modifique la línea como sigue:
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" Windows Server 2003, Enterprise DSREPAIR" /FASTDETECT /NOEXECUTE=OPTOUT /3GB /userva=2900 /maxmem=2944  /safeboot:dsrepair
    Nota la memoria no tiene una gran influencia en la desfragmentación sin conexión porque la tarea no es almacenable en caché.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 948603 - Última revisión: martes, 04 de marzo de 2008 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Palabras clave: 
kbmt kberrmsg kbtshoot kbexpertiseinter kbprb KB948603 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 948603

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com