Message d'erreur lorsque vous essayez à une base de données sur un ordinateur Windows Server 2003: « opération s'est terminé avec erreur-1011 (JET_errOutOfMemory, absence de mémoire) »

Traductions disponibles Traductions disponibles
Numéro d'article: 948603 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Envisagez le scénario suivant :
  • Vous exécutez la maintenance de base de données Active Directory répertoire service dans Windows Server 2003.
  • Vous redémarrez en mode Restauration des services d'annuaire pour vérifier la base de données ou pour nettoyer les.
Dans ce scénario, lorsque vous exécutez une tâche de défragmentation hors connexion, la sortie suivante peut s'afficher :

Gestion de fichiers : compact à <target> Ouverture base de données [actif]. Commande en cours d'exécution : C:\WINDOWS\system32\esentutl.exe /d "<source> \ntds.dit" /t "<target> \ntds.dit" / p / o défragmentation lancement mode... Base de données : <source> \ntds.dit Temp. Base de données : <target> \ntds.dit défragmentation statut % achevé 0 20 10 40 30 60 50 80 70 100 90 |----|----|----|----|----|----|----|----|----|----|....................... Opération terminée avec erreur-1011 (JET_errOutOfMemory, mémoire insuffisante) après 1431.78 secondes. Générées 0xfffffc0d(-1011) de code de sortie de processus
Progression le fait de tâche défragmentation avant cette sortie erreur dépend de la taille de la base de données et la configuration du serveur. Bases de données plus petits ne peuvent pas rencontrer ce problème.

Dans ce scénario, vous n'exécutez pas de mémoire virtuelle et il existe suffisamment de mémoire physique installée. Peu si vous exécutez la tâche de défragmentation et dont la /3 GB commutateur dans le fichier Boot.ini.

note Ce problème ne se produit pas sur les systèmes 64 bits.

Cause

Ce problème se produit si l'ordinateur Windows Server 2003 a plus de 3 gigaoctets (Go) de mémoire physique. Dans ce cas, l'utilitaire Esentutl.exe donne cache incorrecte taille conseils au moteur de base de données. Par conséquent, le moteur de base de données rencontre une erreur d'allocation du cache, et il arrête la défragmentation hors connexion.

Ce problème ne se produit pas sur les systèmes 64 bits car le calcul du cache de l'utilitaire Esentutl.exe diffère considérablement sur ces systèmes.

Résolution

Pour résoudre ce problème, procédez comme suit :
  1. Copiez la ligne dans le fichier Boot.ini qui sert à redémarrer Windows Server 2003.
  2. Collez cette ligne sous la ligne d'origine et puis le modifier avoir l'aspect suivant :
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" Windows Server 2003, Enterprise DSREPAIR" /FASTDETECT /NOEXECUTE=OPTOUT /3GB /userva=2900 /maxmem=<memory that is available to the operating system> /safeboot:dsrepair
    Pour basculer entre les modes de démarrage, vous pouvez commentaire la ligne applicable dans le fichier Boot.ini. Cela signifie également ne que ne pas devoir accéder à la console du serveur pour basculer entre les modes de démarrage.
  3. Réduire la mémoire disponible pour le système d'exploitation afin que l'utilitaire Esentutl.exe ne donne pas cache incorrecte conseils de taille. 2048 est une valeur qui fonctionne pour toutes les configurations. 2944 est une valeur travail pour les configurations / 3 GB. Par exemple, pour une configuration /3G, modifiez la ligne comme suit :
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" Windows Server 2003, Enterprise DSREPAIR" /FASTDETECT /NOEXECUTE=OPTOUT /3GB /userva=2900 /maxmem=2944  /safeboot:dsrepair
    Remarque la mémoire n'a pas une grande influence sur la défragmentation hors connexion car la tâche n'est pas peuvent être mises en cache.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Propriétés

Numéro d'article: 948603 - Dernière mise à jour: mardi 4 mars 2008 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Mots-clés : 
kbmt kberrmsg kbtshoot kbexpertiseinter kbprb KB948603 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 948603
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com