Mensagem de erro quando tenta verificar uma base de dados num computador com o Windows Server 2003: "A operação terminou com erro-1011 (JET_errOutOfMemory, memória esgotada)"

Traduções de Artigos Traduções de Artigos
Artigo: 948603 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Considere o seguinte cenário:
  • Manutenção de base de dados do Active Directory directório serviço está a executar no Windows Server 2003.
  • É de reiniciar em de restauro dos serviços do modo para verificar a base de dados ou para limpá-lo.
Neste cenário, quando executa uma tarefa de desfragmentação offline, poderá receber a seguinte saída:

<target>Manutenção de ficheiros: compact <destino> Abrir base de dados [actual]. Executar comando: C:\WINDOWS\system32\esentutl.exe /d "<source> \ntds.dit" /t "<target> \ntds.dit" /p /o iniciar DESFRAGMENTAÇÃO modo... <source>Base de dados: <origem> \ntds.dit Temp. <target>Base de dados: <destino> \ntds.dit estado da desfragmentação (% concluída) 0 10 20 30 40 50 60 70 80 90 100 |----|----|----|----|----|----|----|----|----|----|....................... Operação terminada com o erro-1011 (JET_errOutOfMemory, memória esgotada) após 1431.78 segundos. 0Xfffffc0d(-1011) de código de saída do processo de expansão
O progresso que torna a tarefa a desfragmentação antes desta saída de erro ocorre depende no tamanho da base de dados e a configuração do servidor. Bases de dados mais pequenos poderão não detectar este problema.

Neste cenário, não execute esgotada a memória virtual e não existe suficiente memória física instalada. Não é importante se estiver a executar a tarefa de desfragmentação em conjunto com o / 3 GB no ficheiro Boot.ini.

Nota Este problema não ocorre em sistemas de 64 bits.

Causa

Este problema ocorre se o computador baseado no Windows Server 2003 tiver mais do que 3 gigabytes (GB) de memória física. Neste caso, o utilitário Esentutl.exe permite cache incorrecta tamanho sugestões o motor de base de dados. Por conseguinte, o motor de base de dados tiver um erro de atribuição de cache e pára a desfragmentação offline.

Este problema não ocorre em sistemas de 64 bits porque o cálculo de cache do utilitário Esentutl.exe difere significativamente nestes sistemas.

Resolução

Para resolver este problema, siga estes passos:
  1. Copie a linha no ficheiro Boot.ini é utilizado para reiniciar o Windows Server 2003.
  2. Colar esta linha abaixo da linha original e, em seguida, modificá-la para ser semelhantes ao seguinte:
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" Windows Server 2003, Enterprise DSREPAIR" /FASTDETECT /NOEXECUTE=OPTOUT /3GB /userva=2900 /maxmem=<memory that is available to the operating system> /safeboot:dsrepair
    para alternar entre modos de arranque, pode comentar a linha aplicável no ficheiro Boot.ini. Isto também significa que não é necessário que aceder a consola do servidor para alternar entre modos de arranque.
  3. Reduza a memória disponível para o sistema operativo para que o utilitário Esentutl.exe não lhe cache incorrecta sugestões de tamanho. 2048 é um valor que funciona para todas as configurações. 2944 é um valor trabalho para configurações de 3 GB. Por exemplo, para uma configuração de 3 G, modifique a linha da seguinte forma:
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" Windows Server 2003, Enterprise DSREPAIR" /FASTDETECT /NOEXECUTE=OPTOUT /3GB /userva=2900 /maxmem=2944  /safeboot:dsrepair
    NOTA: A memória não tem uma grande influência sobre a desfragmentação offline porque a tarefa não é cacheable.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Propriedades

Artigo: 948603 - Última revisão: 4 de março de 2008 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
Palavras-chave: 
kbmt kberrmsg kbtshoot kbexpertiseinter kbprb KB948603 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 948603

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com