Fehlermeldung, wenn Sie versuchen, mit Access Offline in Microsoft Dynamics CRM 4.0-Client für Outlook offline zu gehen: "Verschieben von Daten für Entität"Plug-in-Assembly"während der Aktion einfügen, CountRows = [Anzahl]"

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 948629 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie versuchen, mit Access Offline im Microsoft Dynamics CRM 4.0-Client für Microsoft Outlook offline zu gehen, wird sinngemäß folgende Fehlermeldung:
Fehler beim Verschieben von Daten für Entität "Plug-in-Assembly" während der Aktion einfügen, CountRows = Number. Wenden Sie die Microsoft Dynamics CRM-Administrator.
Hinweis: In dieser Fehlermeldung ist Number ein Platzhalter für die tatsächliche Anzahl der Zeilen.

Dieses Problem, wenn zahlreiche Workflows vorhanden sind.

Ursache

Dieses Problem, weil Microsoft Dynamics CRM 4.0 eine Zeile fügt in der Tabelle PluginAssemblyBase und WorkflowBase-Tabelle beim erneuten eine Workflowregel veröffentlichen. Microsoft Dynamics CRM 4.0 fügt immer die Zeile, selbst wenn die Workflowregel nicht geändert wird. Wenn Sie die Workflowregel oft erneut veröffentlichen, enthält die PluginAssemblyBase-Tabelle sehr viele Daten für diese bestimmten Workflow-Regel. Daher wird sehr viele Daten auf der lokalen Microsoft SQL Server synchronisiert Express Edition-Datenbank beim Versuch, offline zu gehen.

Lösung

Dieses Problem wird in das neueste kumulative Updaterollup für Microsoft Dynamics CRM 4.0 behoben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
949256Microsoft Dynamics CRM 4.0-Updates und hotfixes

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Wenn Sie die Plattform-Ablaufverfolgung aktivieren, erhalten Sie auch eine Fehlermeldung etwa folgenden Inhalts angezeigt:
[DateTime1] Process:Microsoft.Crm.Application.Hoster |Organization:00000000 - 0000 - 0000 - 0000 - 000000000000 |Thread: 18(MSCRM:-OfflineSync.SyncThreadMethod) |Category: Ausnahme |User: 00000000-0000-0000-0000-000000000000 |Level: Fehler | CrmEventLog.WriteEntry
am CrmEventLog.WriteEntry (EventLogEntryType EventType, Int64 EventId, Boolean TraceFailure, Object [] Werte)
am CrmEventLog.WriteEntry (EventLogEntryType EventType, Int64 EventId, Object [] Werte)
am Utility.Log(EventLogEntryType type, Int64 eventId, String message)
am Utility.LogTrace(EventLogEntryType type, Int64 eventId, String message)
am Utility.LogTraceError (String Message)
am SyncData.DoBatchStep(ITransferDataProvider transferDataProvider, String entityName, SyncAction action, Int32 batchRows)
am SyncData.DoBatch (ITransferDataProvider TransferDataProvider, EntityName Zeichenfolge, Int32 CountRows, SyncAction Aktion, Int32 TotalCompleted, Int32 insgesamt)
am SyncData.ExecuteBatch(ITransferDataProvider transferDataProvider, String entityName, Int32 countRows, SyncAction action, Int32 totalCompleted, Int32 total)
am SyncData.MoveData(String syncInfo, ITransferDataProvider transferDataProvider, Int32 progressSteps)
am SyncData.Sync (ITransferDataProvider TransferDataProvider, CallPriority Int32)
am OfflineSync.SyncThreadMethod()
am ThreadHelper.ThreadStart_Context (Object State)
am ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
am ThreadHelper.ThreadStart()
>Konnte die folgende Ereignismeldung in das Ereignisprotokoll zu schreiben.
EventType:Error
EventId = 3221231472
Inhalt: Einfügen für Entität ist fehlgeschlagen 'PluginAssembly', BatchRows = 0 mit Ausnahme System.FormatException: Index (nullbasiert) muss größer oder gleich Null und kleiner als die Größe der Argumentliste sein.
am System.Text.StringBuilder.AppendFormat (IFormatProvider Provider, Format String, Object [] Args)
am System.String.Format(IFormatProvider provider, String format, Object[] args)
am System.String.Format (Format String, Object arg0)
am Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DownloadBCPFile(String bcpFileName, BinaryReader& readStream, Int64 fileSize)
am Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.GetBCPFile(String entityName, Action action, Int32 batchSize)
am Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.ExecuteInsert(String entityName, Int32 count)
am Microsoft.Crm.Application.Outlook.OfflineSync.SyncData.DoBatchStep(ITransferDataProvider transferDataProvider, String entityName, SyncAction action, Int32 batchRows)
Die Ausnahmeinformationen sind:
System.ComponentModel. Win32Exception: Die Ereignisprotokolldatei ist voll

[DateTime2] Process:Microsoft.Crm.Application.Hoster |Organization:00000000 - 0000 - 0000 - 0000 - 000000000000 |Thread: 18(MSCRM:-OfflineSync.SyncThreadMethod) |Category: Ausnahme |User: 00000000-0000-0000-0000-000000000000 |Level: Fehler | CrmEventLog.WriteEntry
am CrmEventLog.WriteEntry (EventLogEntryType EventType, Int64 EventId, Boolean TraceFailure, Object [] Werte)
am CrmEventLog.WriteEntry (EventLogEntryType EventType, Int64 EventId, Object [] Werte)
am Utility.Log(EventLogEntryType type, Int64 eventId, String message)
am Utility.LogTrace(EventLogEntryType type, Int64 eventId, String message)
am Utility.LogTraceError (String Message)
am BcpTransferDataProvider.GetBCPFile(String entityName, Action action, Int32 batchSize)
am BcpTransferDataProvider.ExecuteInsert (EntityName String, Int32 Count)
am SyncData.DoBatchStep(ITransferDataProvider transferDataProvider, String entityName, SyncAction action, Int32 batchRows)
am SyncData.DoBatch(ITransferDataProvider transferDataProvider, String entityName, Int32 countRows, SyncAction action, Int32 totalCompleted, Int32 total)
am SyncData.ExecuteBatch(ITransferDataProvider transferDataProvider, String entityName, Int32 countRows, SyncAction action, Int32 totalCompleted, Int32 total)
am SyncData.MoveData (String SyncInfo, ITransferDataProvider TransferDataProvider, ProgressSteps Int32)
am SyncData.Sync (ITransferDataProvider TransferDataProvider, CallPriority Int32)
am OfflineSync.SyncThreadMethod()
am ThreadHelper.ThreadStart_Context (Object State)
am ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
am ThreadHelper.ThreadStart()
>Konnte die folgende Ereignismeldung in das Ereignisprotokoll zu schreiben.
EventType:Error
EventId = 3221231472
Contents:GetBCPFile() Fehler bei der Aktion einfügen für Entität 'PluginAssembly', BatchRows = 89 mit Ausnahme System.NET.WebException: remote-Server hat einen Fehler zurückgegeben: (401) Unauthorized. ---> System.ComponentModel. Win32Exception: der Anmeldeversuch ist fehlgeschlagen
am System.Net.NTAuthentication.GetOutgoingBlob (Byte []-IncomingBlob, Boolean ThrowOnError, SecurityStatus & StatusCode)
am System.Net.NTAuthentication.GetOutgoingBlob (IncomingBlob Zeichenfolge)
am System.Net.NegotiateClient.DoAuthenticate(String challenge, WebRequest webRequest, ICredentials credentials, Boolean preAuthenticate)
am System.Net.NegotiateClient.Authenticate(String challenge, WebRequest webRequest, ICredentials credentials)
am System.Net.AuthenticationManager.Authenticate(String challenge, WebRequest request, ICredentials credentials)
am System.Net.AuthenticationState.AttemptAuthenticate(HttpWebRequest httpWebRequest, ICredentials authInfo)
am System.Net.HttpWebRequest.CheckResubmitForAuth()
am System.Net.HttpWebRequest.CheckResubmit (Ausnahme & e)
Hinweis: Date ist ein Platzhalter für das aktuelle Datum. Time1 und Time2 sind Platzhalter für die tatsächlichen Zeiten.

Weitere Informationen zum Aktivieren der Ablaufverfolgung in Microsoft Dynamics CRM finden Sie im folgenden Artikel der Microsoft Knowledge Base:
907490Zum Aktivieren der Ablaufverfolgung in Microsoft Dynamics CRM
Weitere Informationen zur Terminologie, mit dem Microsoft Software Updates, finden Sie in der folgenden Artikeln der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates
887283Microsoft Business Solutions CRM-Softwarehotfix und Update Packen Namensstandards

Eigenschaften

Artikel-ID: 948629 - Geändert am: Donnerstag, 12. Februar 2009 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM for Microsoft Office Outlook
  • Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access, wenn verwendet mit:
    • Microsoft Dynamics CRM 4.0
Keywords: 
kbmt kbfix kbautohotfix kberrmsg kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver KB948629 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 948629
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com