Windows Server 2003 ファイル サーバーを Windows Server 2008 にアップグレードした後、リモート暗号化ファイルにアクセスできません。

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文書番号: 948690
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現象

次のシナリオを検討してください。
  • Windows Server 2003 ベースのファイル サーバーがあります。また、プレリリース Windows Server 2008 ベースのファイル サーバーを与えます。
  • このファイル サーバーのホストは、リモートでファイルを暗号化。
  • このファイル サーバーは、Windows Server 2008 にアップグレードします。
このシナリオでは、リモートからの暗号化されたファイルにアクセスしようとすると、次のエラー メッセージが表示されます。
アクセスが拒否されました
ユーザー対話形式で、アップグレードする前に、ファイル ・ サーバにログオンした場合、この問題は発生しません。

原因

この問題が発生するは、Windows ファイル サーバーを Windows Server 2008 にアップグレードすると、特別なユーザー プロファイルが移行されないこと。したがって、暗号化ファイルにアクセスしようとすると、アップグレードされたファイル サーバーは、特別なプロファイルを認識されません。その後、アップグレードされたファイル サーバー新しい EFS 暗号化キーを持つ新しいプロファイルを作成します。これらの新しいキーの元のキーとは異なります。したがって、暗号化済みのファイルにアクセスできません。

Windows ファイル サーバーに保存されているファイルを暗号化すると、ファイルの実際の暗号化、ファイル サーバーに発生します。特別なユーザー プロファイルは、Windows Server 2003 ベースのファイル サーバー上に作成されます。この特別なユーザー プロファイルを作成し、暗号化ファイル システム (EFS) の暗号化キーを格納する使用されます。その後、ユーザーがファイル サーバー上の暗号化されたファイルにアクセスするたびに、ユーザーに代わってこの特別なプロファイルが読み込まれます。以前に作成した暗号化キーが使用されます。

解決方法

解決するには、この問題を入手してください投稿アップグレード EFS 回復ツール、マイクロソフト ・ ダウンロード ・ センターから。

メモ EFS 回復ツールは必要ありません EFS ファイルが存在する Windows Server 2003 ベースのコンピューターがインプレースが Windows Server 2008 R2 にアップグレードします。

次のファイルは、Microsoft ダウンロード センターからダウンロードできます。

元に戻す画像を拡大する
ダウンロード
ポストをアップグレード EFS 回復のツール 1.0 パッケージします。

マイクロソフトのサポート ファイルをダウンロードする方法の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトは、このファイルのウイルスをスキャンしました。マイクロソフトは、ファイルが転記された日付に利用可能な最新のウイルス検出ソフトウェアを使用します。ファイルは、ファイルに不正な改変を防止するセキュリティが強化されたサーバーに格納されます。

EFS 回復ツールは、アップグレードされたサーバー上の EFS キーが登録されていないアカウントのプロファイル ディレクトリをスキャンします。アカウントが見つかった場合は、ツール新しいプロファイルを作成し、EFS キーを新しいプロファイルにコピーします。ツールは、未登録のプロファイルを ~efs.000 ファイルにアーカイブされます。

EFS の回復ツールを実行する方法

サーバー上で管理者特権のコマンド プロンプトからこのツールを実行する必要があります。EfsUpgRecoverAccts.exe とを実行することができます 2 つのスイッチには、
  • /D
    のみを検出します。未登録のプロファイルを回復するには、スキャンしますが、リカバリは実行されません。
  • /R
    リカバリを実行します。
出力フォーマット] タブです。出力をファイルにリダイレクトすることができます。たとえば、次のコマンドを使用できます。
EfsUpgRecoverAccts/R > C:\Efsfix.log
リターン コードは、ツールを実行するときに発生する問題のレベルを示します。
  • 0: 警告またはエラーを報告なし。
  • 1: 警告を出力を確認してください。
  • 2: エラー、出力を確認してください。
  • 3 +: 致命的なエラー、ツールを実行できませんでした。

状況

マイクロソフトでは、この「対象」に記載されているマイクロソフト製品の問題として認識しています。

プロパティ

文書番号: 948690 - 最終更新日: 2011年8月11日 - リビジョン: 4.0
キーワード:?
kbtshoot kbprb kbexpertiseinter kbmt KB948690 KbMtja
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英語版 KB:948690
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