Help and Support
Hotfix Download Available

You cannot use the Reg.exe utility to access 64-bit registry keys on a 64-bit computer from a computer that is running a 32-bit version of Windows Server 2003

Article ID:948698
Last Review:March 10, 2008
Revision:1.3
On This Page

SYMPTOMS

On a computer that is running a 32-bit version of Windows Server 2003, the Reg.exe utility cannot access 64-bit registry keys on a computer that is running a 64-bit version of Windows Server 2003.

Notes
This problem occurs when the 32-bit computer has Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed.
This problem does not occur on a computer that is running Windows 2000.

Back to the top

CAUSE

This problem occurs because of the registry redirector feature and because of the registry reflection feature. These features were introduced in Windows Server 2003 SP1.

Back to the top

RESOLUTION

A hotfix is available to resolve this problem. After you apply this hotfix, a new /reg switch is added to the Reg.exe utility. This switch enables the utility to remotely access a 64-bit registry from a 32-bit version of Windows Server 2003. The following is a sample command line:
reg query \\64server\HKLM\software /reg:64
Note The 64server placeholder represents the computer name of the remote 64-bit computer.

The /reg:64 switch enables the source computer to receive the 64-bit view of the remote registry. Similarly, the /reg:32 switch enables the source computer to receive the 32-bit view of the remote registry.

If you do not specify the /reg switch, the source computer receives a view of the remote registry that matches the client computer platform. Therefore, the 32-bit source computer receives a 32-bit view of the remote registry.

Back to the top

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP1 or SP2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Reg.exe5.2.3790.309681,92028-Feb-200811:58x86
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Reg.exe5.2.3790.424481,92028-Feb-200809:50x86
Windows Server 2003 with SP1, IA-64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Reg.exe5.2.3790.3096200,19228-Feb-200812:30IA-64SP1Not Applicable
Wreg.exe5.2.3790.309681,92028-Feb-200812:30x86SP1WOW
Windows Server 2003 with SP2, IA-64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Reg.exe5.2.3790.4244200,19228-Feb-200812:38IA-64SP2Not Applicable
Wreg.exe5.2.3790.424481,92028-Feb-200812:38x86SP2WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Reg.exe5.2.3790.3096124,92828-Feb-200812:29x64SP1Not Applicable
Wreg.exe5.2.3790.309681,92028-Feb-200812:29x86SP1WOW
Windows Server 2003 with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Reg.exe5.2.3790.4244124,92828-Feb-200812:41x64SP2Not Applicable
Wreg.exe5.2.3790.424481,92028-Feb-200812:41x86SP2WOW

Back to the top

WORKAROUND

To work around the issue, run the Reg.exe utility on a Windows 2000-based computer or on a computer that is running a 64-bit version of Windows Server 2003.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

32-bit applications can receive only a 32-bit view of the remote registry unless these applications use the KEY_WOW64_64KEY flag in a post-Windows Server 2003 SP1 environment. For more information, see the following table:
FlagDescription
KEY_WOW64_64KEYThis enables a 64-bit or a 32-bit program to open a 64-bit registry key on a 64-bit Windows platform. This flag must be combined with other flags in this table that either query or access registry values. To do this, you can use the OR operator.
KEY_WOW64_32KEYThis enables a 64-bit or a 32-bit program to open a 32-bit registry key on a 64-bit Windows platform. This flag must be combined with other flags in this table that either query or access registry values. To do this, you can use the OR operator.

For more information about the registry redirector feature, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/aa384232.aspx (http://msdn.microsoft.com/en-us/library/aa384232.aspx)
For more information about remote registry access in 64-bit versions of Windows, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/aa384237(VS.85).aspx (http://msdn.microsoft.com/en-us/library/aa384237(VS.85).aspx)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Microsoft Windows Server 2003, Datacenter x64 Edition
Microsoft Windows Server 2003, Enterprise x64 Edition
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Microsoft Windows Server 2003, Standard x64 Edition
Microsoft Windows Server 2003, Standard Edition (32-bit x86)

Back to the top

Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB948698

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.