Help and Support

Article ID: 948800 - Last Review: March 17, 2008 - Revision: 1.1

Error message when you check the properties of a contact in Outlook: "The name cannot be resolved. The bookmark is not valid"

Expand all | Collapse all

SYMPTOMS

When you check the properties of a contact or create a new profile in Microsoft Outlook, you receive the following error message:
The name cannot be resolved. The bookmark is not valid.

CAUSE

This problem occurs because the Authenticated Users group does not have the correct permissions for the default global address list (GAL).

RESOLUTION

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To resolve this problem, use the ADSIEdit.msc tool to confirm that the default GAL object is configured for the following permissions.
Collapse this tableExpand this table
AccountsPermissionApply to
Authenticated UsersOpen Address ListThis object only
Authenticated UsersList ContentsThis object and child objects
Domain Admins Full ControlThis object only
SystemFull ControlThis object only

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

In Microsoft Exchange Server 2007, you can run the following command to view the list of permissions:
Get-GlobalAddressList "Default Global Address List" | Get-ADPermission
This problem also occurs if the server that is running Exchange Server cannot communicate with the NSPI interface of the global catalog. To resolve this problem, restart the global catalog.

APPLIES TO
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
Keywords: 
kbtshoot kbexpertiseinter kbexchdirectory KB948800

Article Translations