Puede experimentar un rendimiento lento al ejecutar o modificar los flujos de trabajo en Microsoft Dynamics CRM 4.0

Seleccione idioma Seleccione idioma
Id. de artículo: 948843 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Al ejecutar o modificar los flujos de trabajo en Microsoft Dynamics CRM 4.0, puede experimentar un rendimiento bajo.

Causa

Este problema se produce debido a que Microsoft Dynamics CRM 4.0 crea registros para todas las instancias de flujo de trabajo inactivas en la tabla PluginAssemblyBase. Además, si se modifica una regla de flujo de trabajo, Microsoft Dynamics CRM 4.0 crea un registro en la tabla PluginAssemblyBase y otro en la tabla PluginTypeBase. Sin embargo, nunca se quitan estos registros. Por lo tanto, si se modifican en muchas ocasiones las reglas de flujo de trabajo, las tablas PluginAssemblyBase y PluginTypeBase aumentan de tamaño.

Solución

Este problema se corrigió en el paquete acumulativo de actualizaciones más reciente para Microsoft Dynamics CRM 4.0. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
949256 Actualizaciones y revisiones de Microsoft Dynamics CRM 4.0

Para mejorar el rendimiento de esta revisión, cree el índice siguiente en la base de datos Organización_MSCRM.
Notas
  • En la siguiente secuencia de comandos, el marcador de posición de nombreDeOrganización representa el nombre real de la base de datos de Microsoft CRM. Se debe reemplazar el marcador de posición por el nombre real de la base de datos.
  • No cree el siguiente índice si ya tiene uno con las mismas columnas de clave. Para ver los índices existentes, ejecute el código siguiente:
    sp_helpindex AsyncOperationBase




USE nombreDeOrganización_MSCRM 

CREATE NONCLUSTERED INDEX CRM_AsyncOperation_WorkflowCleanupQuery ON [AsyncOperationBase] (OperationType,StateCode,WorkflowActivationId)

Use el Editor de trabajo de ScaleGroup de CRM 4 para programar el servicio de eliminación de Microsoft Dynamics CRM 4 a fin de que se ejecute tras el horario laboral habitual para minimizar sus efectos en el rendimiento de usuario de Microsoft Dynamics CRM. Para obtener el Editor de trabajo de implementación de CRM 4, visite el siguiente sitio web de Microsoft:
http://code.msdn.microsoft.com/ScaleGroupJobEditor
  1. Seleccione la organización.
  2. Cambie el tipo de trabajo a Servicio de eliminación.
  3. Establezca la hora de base en la hora de menor uso de Microsoft Dynamics CRM o fuera del horario laboral.
  4. Se recomienda que establezca o deje el valor de Volver a programar trabajo en 1440 minutos. De esta forma el servicio se ejecutará diariamente a la hora especificada en el campo Hora de base.
Nota La primera vez que ejecute el servicio de eliminación de Microsoft Dynamics CRM 4.0 después de aplicar esta revisión, es posible que deba actualizar la opción OLEDBTimeout a un periodo de tiempo superior al valor predeterminado. Se recomienda que cree una nueva subclave REG_DWORD si aún no existe. Asigne un nombre a la subclave OLEDBTimeout de HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM\ en el servidor o servidores de Microsoft Dynamics CRM 4.0. Establezca el valor en un valor decimal 86400. Una vez que se haya ejecutado el servicio de eliminación Microsoft Dynamics CRM 4.0, es recomendable que elimine la clave del Registro OLEDBTimeout en HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM o que la establezca en un valor decimal entre 60 y 300 para impedir que las consultas que se ejecutan durante mucho tiempo causen un bloqueo de SQL excesivo y un bajo rendimiento de la aplicación.

Más información

Una vez instalada esta revisión, es posible que vea los siguientes errores en el registro de eventos de la aplicación de los servidores de Microsoft Dynamics CRM 4.0 si no sigue los pasos para mejorar el rendimiento indicados a continuación en la sección de solución la primera o primeras veces que se ejecute el servicio de eliminación.
. Tipo de evento: error Origen del evento: Categoría del evento de MSCRMDeletionService: ningún Id. de evento: 16387 Fecha: 26/01/09 Hora: 11:41:54 a.m. Usuario: N/D Equipo: Descripción de CRMSERVER: Error: El servicio de eliminación no pudo limpiar la tabla=CleanupInactiveWorkflowAssembliesProcedure Para obtener más información, consulte el Centro de ayuda y soporte técnico en http://go.microsoft.com/fwlink/events.asp.

Referencias

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
948629 Aparece un mensaje de error al intentar desconectarse en el cliente de Microsoft Dynamics CRM 4.0 para Outlook con acceso sin conexión: "Error al mover los datos de la entidad 'Ensamblado de complemento' durante la acción Insertar, countRows=[Number]"
Para obtener más información acerca de la terminología que se usa para describir las actualizaciones de software de Microsoft, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
887283 Nomenclatura estándar del paquete de actualizaciones y revisiones de software de Microsoft Business Solutions CRM

Propiedades

Id. de artículo: 948843 - Última revisión: lunes, 10 de octubre de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft CRM client for Microsoft Office Outlook sobre las siguientes plataformas
    • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM 4.0
Palabras clave: 
kbfix kbautohotfix kbexpertiseinter kbmbsmigrate kbqfe kbHotfixServer KB948843

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com