Pri spúšťaní alebo úprave pracovných postupov v systéme Microsoft Dynamics CRM 4.0 môže počítač pracovať pomaly

Preklady článku Preklady článku
ID článku: 948843 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Pri spúšťaní alebo úprave pracovných postupov v systéme Microsoft Dynamics CRM 4.0 môže počítač pracovať pomaly.

PRICINA

Príčinou tohto problému je skutočnosť, že systém Microsoft Dynamics CRM 4.0 vytvára záznamy pre všetky neaktívne inštancie pracovného postupu v tabuľke PluginAssemblyBase. Ak upravujete pravidlo pracovného postupu, systém Microsoft Dynamics CRM 4.0 vytvára záznam v tabuľke PluginAssemblyBase a záznam v tabuľke PluginTypeBase. Tieto záznamy sa však nikdy neodstraňujú. Platí preto, že ak pravidlá pracovného postupu upravíte veľakrát, tabuľky PluginAssemblyBase a PluginTypeBase budú veľmi veľké.

RIESENIE

Tento problém sa odstraňuje v najnovšej kumulatívnej súhrnnej aktualizácii systému Microsoft Dynamics CRM 4.0. Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
949256 Aktualizácie a rýchle opravy pre systém Microsoft Dynamics CRM 4.0

Ak chcete zvýšiť výkon tejto rýchlej opravy, vytvorte v databáze Organizácia_MSCRM nasledujúci index.
Poznámky
  • Reťazec NázovOrganizácie v nasledujúcom zápise predstavuje skutočný názov databázy systému Microsoft CRM. Tento reťazec by ste mali nahradiť skutočným názvom databázy.
  • Nasledujúci index nevytvárajte, ak už máte index s rovnakými stĺpcami kľúčov indexu. Existujúce indexy zobrazíte spustením nasledujúceho kódu:
    sp_helpindex AsyncOperationBase




USE NázovOrganizácie_MSCRM 

CREATE NONCLUSTERED INDEX CRM_AsyncOperation_WorkflowCleanupQuery ON [AsyncOperationBase] (OperationType,StateCode,WorkflowActivationId)

Pomocou nástroja CRM 4 ScaleGroup Job Editor naplánujte službu odstránenia v rámci systému Microsoft Dynamics CRM 4 tak, aby sa spúšťala po pracovnom čase. Minimalizuje sa tak vplyv na výkon systému Microsoft Dynamics CRM. Nástroj CRM 4 Deployment Job Editor získate na nasledujúcej webovej lokalite spoločnosti Microsoft:
http://code.msdn.microsoft.com/ScaleGroupJobEditor
  1. Vyberte organizáciu.
  2. Zmeňte položku Typ úlohy (Job Type) na možnosť Služba odstránenia (Deletion Service).
  3. Položku Základný čas (Base Time) nastavte na čas, kedy sa systém Microsoft Dynamics CRM najmenej používa, alebo na čas po pracovnom čase.
  4. Položku Znova naplánovať úlohu (Reschedule Job) sa odporúča nastaviť alebo ponechať na nastavení „každých 1 440 minút“. Služba sa tak bude spúšťať každý deň v čase, ktorý je zadaný v poli Základný čas (Base Time).
Poznámka Keď nainštalujete túto rýchlu opravu, pri prvom spustení služby odstránenia v rámci systému Microsoft Dynamics CRM 4.0 môže byť potrebné aktualizovať nastavenie položky OLEDBTimeout na dlhší čas, než je predvolená hodnota. Odporúča sa vytvoriť nový podkľúč REG_DWORD (ak ešte neexistuje). Priraďte mu názov OLEDBTimeout a uložte ho do umiestnenia HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM\ na serveri (alebo serveroch) systému Microsoft Dynamics CRM 4.0. Hodnotu tohto podkľúča nastavte na desiatkovú hodnotu 86 400. Po spustení služby odstránenia v rámci systému Microsoft Dynamics CRM 4.0 s nainštalovanou opravou sa dôrazne odporúča odstrániť kľúč OLEDBTimeout databázy Registry v umiestnení HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM alebo nastaviť jeho hodnotu na desiatkovú hodnotu v rozsahu 60 až 300, aby dotazy, ktoré prebiehajú dlhšie, nespôsobovali nadmerné blokovanie služby SQL a zníženie výkonu aplikácie.

DALSIE INFORMACIE

Ak pri prvom spustení služby odstránenia nevykonáte kroky potrebné na zvýšenie výkonu, ktoré sú uvedené nižšie v časti riešenia, po nainštalovaní tejto rýchlej opravy sa môžu v denníku udalostí aplikácií na serveroch systému Microsoft Dynamics CRM 4.0 zobraziť nasledujúce chyby.
. Typ udalosti (Event Type): Zdroj udalosti chyby (Error Event Source): MSCRMDeletionService Kategória udalosti (Event Category): Žiadna (None) ID udalosti (Event ID): 16387 Dátum (Date): 26. 1. 2009 Čas (Time): 11:41:54 Používateľ (User): Neudáva sa (N/A) Počítač (Computer): CRMSERVER Popis (Description): Chyba (Error): Službe odstránenia sa nepodarilo vyčistiť tabuľku table=CleanupInactiveWorkflowAssembliesProcedure (Deletion Service failed to clean up table=CleanupInactiveWorkflowAssembliesProcedure) Ďalšie informácie získate v Centre pomoci a technickej podpory na lokalite http://go.microsoft.com/fwlink/events.asp.

ODKAZY

Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
948629 Pri pokuse o prechod do režimu offline v klientovi systému Microsoft Dynamics CRM 4.0 pre program Outlook s funkciou prístupu v režime offline sa zobrazuje chybové hlásenie: Nepodarilo sa presunúť údaje entity Saved View (Uložené zobrazenie) počas akcie Insert, countRows=13 (Failed move data for entity 'Saved View' during action Insert, countRows=13)
Ďalšie informácie o terminológii používanej na popis aktualizácií softvéru od spoločnosti Microsoft získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
824684Popis štandardnej terminológie použitej na popis aktualizácií softvéru od spoločnosti Microsoft
887283 Štandardy pomenúvania balíkov rýchlych opráv a aktualizácií softvéru systému Microsoft Business Solutions CRM

Vlastnosti

ID článku: 948843 - Posledná kontrola: 11. októbra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft CRM client for Microsoft Office Outlook, pri použití s produktom:
    • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM 4.0
Kľúčové slová: 
kbfix kbautohotfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver KB948843

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com