Artigo: 948911 - Última revisão: quarta-feira, 28 de Maio de 2008 - Revisão: 2.0

Um disco rígido externo que se baseia a norma IEEE 1394 não é detectado num computador com o Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows XP e Windows Vista
Expandir tudo | Reduzir tudo

Sintomas

Liga um disco rígido externo que se baseia o Institute of Electrical and Electronics Engineers, Inc. (IEEE) 1394 padrão a um computador baseado no Windows Vista. No entanto, não é detectado no disco rígido externo.

Este sintoma ocorre em discos rígidos externos duplo capacidade que podem ser ligados utilizando uma ligação IEEE 1394 ou uma ligação USB. No entanto, este sintoma ocorre apenas quando o disco rígido externo está ligado através de uma ligação IEEE 1394.

Causa

Este problema ocorre se o disco rígido externo não suporta o parâmetro MODE_SELECT .

Resolução

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Para resolver este problema, defina o valor de registo LegacyFlags com um valor hexadecimal de 200. Para o fazer, siga estes passos:
  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
     Start button
    , escreva regedit na caixa Iniciar procura e, em seguida, clique em regedit na lista programas .

    Reduzir esta imagemExpandir esta imagem
     User Account Control permission
    Se lhe for pedido para uma palavra-passe de administrador ou confirmação, escreva a palavra-passe ou clique em continuar .
  2. Localize e, em seguida, clique na seguinte subchave de registo, onde device_ID é o número de identificação para o disco rígido externo e hardware_key é a chave para o disco rígido externo:
    parâmetros de HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SBP2\device_ID\hardware_key\Device
  3. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  4. Escreva LegacyFlags e, em seguida, prima ENTER.
  5. Clique com o botão direito do rato LegacyFlags e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , escreva 200 , clique em hexadecimal na área base e, em seguida, clique em OK .
  7. Saia do Editor de registo.
Para mais informações sobre como resolver este problema, contacte o fabricante do chipset no computador. Para obter informações sobre como contactar o fabricante do chipset no computador, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/gp/vendors (http://support.microsoft.com/gp/vendors)

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbexpertiseinter kbtshoot kbprb KB948911 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 948911  (http://support.microsoft.com/kb/948911/en-us/ )